Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When attempting to ./configure PHP 5.3.3 on Ubuntu 8.04, I get the error:

 checking for libevent >= 1.4.11 install prefix...
 configure: error: Could not find libevent >= 1.4.11 in /usr/local/

I tried installing the libevent-dev and libevent1 packages, but same error.

I then removed the packages, downloaded and compiled libevent from source. Same error.

Locate shows that libevent was installed to /usr/local/lib/libevent.so with all its friends in /usr/local/lib/.

I tried configuring with the option:

--with-libevent-dir=/usr/local/lib/ 

Basically the same error:

 checking for libevent >= 1.4.11 install prefix...
 configure: error: Could not find libevent >= 1.4.11 in /usr/local/lib/

Any suggestions??

share|improve this question

2 Answers 2

Apparently there's a bug in the configure script. The work around is to run:

export LD_LIBRARY_PATH=/usr/local/lib

prior to running ./configure.

share|improve this answer

Did exporting that variable work for you?? If so what OS are you on?

The solution for me (rhel 5.4) was to install libevent from source, details here:

http://www.iainlbc.com/2010/11/configure-error-could-not-find-libevent-1-4-11-when-configuring-php/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.