Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I recently deployed a new website on a VPS thingy using a stackscript, and everything went well. It set up ssh to use my public key and everything. However, when I connect to the server with ssh, I can't TAB to autocomplete, and I can't use the up arrow to pull up previous commands. I've used ssh before and never had this problem. What configuration is responsible for this, and is it safe to change?

share|improve this question
add comment

3 Answers

up vote 1 down vote accepted

The features you're looking for are not part of SSH, they're part of the shell that's run automatically for you when you sign in with SSH. You can run echo $SHELL to see which shell you're currently using. I'm going to assume that you're used to using the bash shell so run bash and see if it behaves like you expect. If it does, run chsh and set your shell to '/bin/bash'. Next time you log in bash will be started for you.

share|improve this answer
add comment

It is most likely the shell you are using - ie not something like bash that you are used to. Try the command chsh to change your shell.

share|improve this answer
add comment

Check the /etc/passwd. Your use must be use /bin/bash in your shell options. BTW, you always can use this features typing bash in your console

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.