Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've got a weird problem in IIS6, I expect it's something silly (I'm a bit rusty on the IIS front).

I can post to my default page fine if I include it in the url (http://localhost/wiki/wiki.asp?pg=Home), but if I post without (http://localhost/wiki/?pg=Home) I get a 405.

If I do a get with that second URL, it works ok.

I don't think it's an ASP error, because I've got 'Send detailed error message to client' selected.

(Note: this is IIS on a workstation)

share|improve this question
    
Same here: HTTP 405 - Resource not allowed. Log file shows: 19:22:17 127.0.0.1 POST /Saml/ 405 –  vitalik Dec 17 '10 at 20:04

1 Answer 1

up vote 2 down vote accepted
+25

This occurs with a post to a URL that doesn't have an exception, in IIS 5.1 (workstation). Here are more details and the solution: http://www.somacon.com/p126.php.

According to this KB article, that default setting was fixed in IIS6, which is why you see it on the workstation only.

share|improve this answer
    
Scott, I'm giving you the benefit of the doubt on this one. I won't have time in the next two days to check! Happy Christmas... –  Benjol Dec 23 '10 at 23:27
    
Thanks Benjol. I believe and hope that it's what you're looking for. Merry Christmas! –  Scott Forsyth - MVP Dec 24 '10 at 20:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.