Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

We installed a clustered SQL 2005 installation on windows 2008 and reattached our san drives from another machine and restored to do a migration to new hardware. There have been a few minor issues, but this one has me stuck.

Trying to populate Full-Text indexes is not working. I create a basic table with some simple text in a new database and get the same results as old indexes.

2010-09-27 10:30:46.85 spid19s     Informational: Full-text Full population initialized for table or indexed view '[SQL_DBA].[dbo].[CIS_Report_Executions]' (table or indexed view ID '1767677345', database ID '5'). Population sub-tasks: 1.
2010-09-27 10:31:15.36 spid19s     Error '0x80070003' occurred during full-text index population for table or indexed view '[SQL_DBA].[dbo].[CIS_Report_Executions]' (table or indexed view ID '1767677345', database ID '5'), full-text key value 0x000001DF. Attempt will be made to reindex it.
2010-09-27 10:31:15.37 spid19s     The component 'MSFTE.DLL' reported error while indexing. Component path 'D:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\Binn\MSFTE.DLL'.
2010-09-27 10:31:15.37 spid19s     Error '0x80070003' occurred during full-text index population for table or indexed view '[SQL_DBA].[dbo].[CIS_Report_Executions]' (table or indexed view ID '1767677345', database ID '5'), full-text key value 0x000001E0. Attempt will be made to reindex it.

The rebuild/repopulate procedure finishes, but I get zero rows in the index. The .dll in the message is present and the service accounts have access to this. My FTData also has data in it, so it seems there wouldn't be permission issue on this folder.

Application throws this error:

“PHP Warning: mssql_query() [function.mssql-query]: message: Full-text catalog 'ikm_PageIndex_FText' is in an unusable state. Drop and re-create this full-text catalog. (severity 16) in E:\Inetpub\knowledgebase_insidemesa\lib\database\mssql.php on line 154”

A microsoft discussion is the only post I found which had claimed to fix this - said it was registry related, but then didn't post the fix.

share|improve this question
    
And that is exactly why SQL Server 2008 got reworked and now stores the full text index in the database files. I suggest kindly you open a ticket with MS PSS (Professional Support Services) and have them help you sort that out. Then update to a better version of SQL Server, 2012 preferred. –  TomTom Jan 3 '13 at 8:42

1 Answer 1

From MSDN:

DirectoryNotFoundException uses the HRESULT COR_E_DIRECTORYNOTFOUND which has the value 0x80070003. Note that DirectoryNotFoundException is also thrown when COM interop programs see the HRESULT STG_E_PATHNOTFOUND, which has the value 0x80030003.

0x80070003 means that the directory cannot be found. It may be that the original location of the FTC has changed when it was attached to another database server. Either fix the path up or drop and re-create the full-text catalog and full-text indexes. SSMS should allow you to script out the indexes with ease.

share|improve this answer
    
I've dropped/created them - didn't fix. All new ft on that db instance has this issue. Two other instances work. –  Sam Sep 28 '10 at 5:45
    
the catalog or the index? –  Nick Kavadias Sep 28 '10 at 5:47
    
check that the paths in sys.fulltext_catalogs are accessible to the process that's running the SQL Server full text search service –  Nick Kavadias Sep 28 '10 at 6:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.