Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a DeLock-branded, Si3132-based eSATA ExpressCard in my MacBook Pro, with the com.SiliconImage.driver.Si3132r5 driver 1.5.16 on 10.5.7.

Every now and then, it apparently decides to go nuts. All I/O to the external drive will be stalled for a few seconds, then continues, then stalls again, and so on. This has appeared a while ago, possibly with the 10.5.5 update. It appears to correspond to a system log message:

4/25/09 7:09:16 PM kernel SCSIPressurePathManager: new active path available, checking, loops = 0

And sure enough, 1) I know the driver works through the SCSI system (i.e., drives are faked as external SCSI ones, not SATA ones), and 2) the most useful Google result I could find has to do with ExpressCards. Other results suggest different drivers, but so far I've only found rebadged versions of SI's 1.1.9 driver (by Sonnet and by Rosewill), which exhibits the same problem. I assume this is some sort of caching bug.

One thing I have yet to try is to install 10.5.4's SCSI-related kernel extensions.

The stalling makes the card virtually useless, as performance via USB runs circles around this.

Update: as of 10.6.1 (10B504) / 1.1.11, this is still occurring.

share|improve this question
    
Any luck with updating to 10.5.7? –  Chealion Jun 6 '09 at 16:21
    
No, the issue is still there in 10.5.7. Still haven't tried using 10.5.4's extensions, though. –  Sören Kuklau Jun 7 '09 at 19:45
    
Please read the ServerFault FAQ: "Please note that Server Fault is not for general computer troubleshooting questions; if you paid for that desktop hardware, and it's your personal workstation, it is unlikely that your question is appropriate for Server Fault." –  Kamil Kisiel Jun 19 '09 at 21:53
add comment

2 Answers

Those links may help you :

http://discussions.apple.com/thread.jspa?messageID=8628956

http://www.snsforums.com/index.php?showtopic=250

http://forums.applenova.com/showthread.php?s=3bbe55948d64dca96ea3ced8d1905626&t=32027

But after many search, there still no clear solution to the problem up to right now...

Hope it may help you but it's seems a very common problem with no known solution...

share|improve this answer
    
That third link is actually a post of mine ;) Thanks, though. –  Sören Kuklau Jun 12 '09 at 5:35
add comment

If upgrading your driver isn't working, you could try downgrading it instead. The vendors website has older versions available:

http://www.siliconimage.com/support/searchresults.aspx?pid=32&cat=3

share|improve this answer
    
I should have clarified — 1.1.9 is a downgrade from 1.5.16, which I typically use. 1.1.9 also causes an occasional kernel panic fixed in 1.5.16. –  Sören Kuklau Jun 13 '09 at 14:08
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.