Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I just installed vsftpd on my Ubuntu (Lucid) server and followed the config recommendations. I made sure that "Write_enable=YES".

I'm able to connect via FTP, but when I try to "mput" a local file into /var/www, I get the following error:

"553 Could not create file."

I believe writing files to the /var/www directory requires sudo access, but when I tried "sudo mput", I got an error msg saying that this was not a valid command.

When I use FireFTP, my writes are still being blocked.

What am I missing?

Thanks.

share|improve this question
add comment

2 Answers 2

up vote 0 down vote accepted

Running sudo mput on your client isn't going to make a bit of difference in your ability to write files on the server, as that command only escalates your permissions on the client machine. Also, setting Write_enable=YES in the vsftpd config is only going to enable the possibility of writing to the ftp server. You need to check the permissions on /var/www itself to see if your user has write access.

Run $ ls -la /var/www, edit your question and post the output.

Also, what's the username you're using with FTP and what groups is that user in?

share|improve this answer
    
I got it working. You're right - I just needed to add write permissions (chmod) for me and the group. Thanks! –  JMan Sep 28 '10 at 16:59
add comment

this might help, optionally you can use sftp with filezilla to write to the directory.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.