Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have just installed a fresh xampp stack on my machine, and can access it from localhost, my pc name, and ip address. There is nothing on it yet, but getting the welcome page fine.

I seem to remember in the past that other users could access my localhost by going to my ip (192.168.2.6) but I can't seem to get it working.

We can both ping each other fine so I don't get what the problem could be.

We have tried a few things in httpd.conf and restarted apache each time but I'm rather confused.

Anyone know if I need to add a VirtualHost entry or is it more likely to be a firewall problem or something similar?

share|improve this question
    
UPDATE: I have added in the http entry in my firewall to forward port 80 to my machine - no change. Disabled my firewall entirely - No change. I don't really see how changing the hosts file will make any difference, as it just maps a name to an ip address, doesn't it? I cant access the server from any other machine using the name or the ip. Any other ideas? Thanks very much for helping. –  slugmandrew Sep 29 '10 at 12:04
add comment

2 Answers

up vote 0 down vote accepted

As far as I'm familiar with it it is indeed a firewall issue. If you're behind a NAT then you should set up your modem/NAT configuration to forward port 80 to your machine.

share|improve this answer
    
So if I log into my router and got to virtual servers and forward port 80 to my host machine's static ip, that should work? I have settings for inbound port range and outbound port range? should they both be 80? –  slugmandrew Sep 29 '10 at 11:38
    
Scratch that. It was right. My router had a pre-made setting which i added to the list. This is what I have: Inbound Port: 80-80, Type: TCP, Private IP: 192.168.2.102, Private Port: 80:80. Still doesn't work :( –  slugmandrew Sep 29 '10 at 11:45
    
Finally worked it out, and it's not doing anything for my reputation (or self-belief!). I had the windows firewall on :D What a dufus. Just added port 80 as an exception through Control Panel. Thanks for the help anyways guys and girls. –  slugmandrew Oct 1 '10 at 9:10
add comment

if you are behind a router then check for NAT settings. if you are on the same subnet/vlan then check for firewall software grants on your xampp host machine.

try using /etc/hosts (or equivalent on windows) on the other machines to bind the xampp host machine name to the ip address of that xampp machine.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.