Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am running Windows 2008, anytime I connect to a PC with RDP..

My keyboard goes crazy.

Ex) If I type l in the RDP it will lock the Remote PC.

Any idea what might cause this?

I have checked the Regional settings and everything is correct and the keyboard language is correct. Everything is working correctly on my local PC with the keyboard.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

On the "Local Resources" tab of your RDP client, change the default "Keyboard" setting to another one.

share|improve this answer
    
I only see Keyboard - Apply key combinations (for example ALT+TAB). –  user55630 Sep 29 '10 at 13:54
2  
That's it. Your problem is linked to a key combination sent to your server. With the default setting of the RDP client, the "Windows" key is often stuck. Windows + L => Lock –  Laurent Sep 29 '10 at 14:03
    
Thanks for your help! –  user55630 Sep 29 '10 at 14:08

This happens to me periodically - just whack the Windows key on your keyboard and that seems to sort it out.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.