Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

and first of all sorry for my english. I've installed an ubuntu server 10.04.1 with apache2, subversion, svn_dav and websvn. (and others services of course, like php5, mysql 5.1, etc). I've configured my svn with multiple repositories, and each one with differents groups and users, like:

/var/myrepos/repo1 group: mygroup1
/var/myrepos/repo2 group: mygroup2
/var/myrepos/repo3 user: johndoe

With an easy access on svn_dav, works perfectly, ie: http://myserver/svnrepo1 accesibly only for users on mygroup1 with theirs users of linux and passwords of svn. Also works for the other repos with their users and groups. But when i tried with websvn, shows all repos without take care than if user on mygroup1 can view repo2 (that's i dont want do). You can login as any user on mygroup1, mygroup2, or johndoe, and you login into all repositories.

I'll try to find a solution and I'll post the news, if anyone can helpme with this I'll preciated so much!!! Thanks for all

I show my files: /etc/apache2/mods-available/dav_svn.conf

<Location /svnrepo1>
    DAV svn
    SVNPath /var/myrepos/repo1
    AuthType Basic
    AuthName "Repositorio Subversion de MD"
    AuthUserFile /etc/apache2/dav_svn.passwd
    Require valid-user
</Location>

<Location /websvn/>
    Options FollowSymLinks
    order allow,deny
    allow from all
    AuthType Basic
    AuthName "Subversion Repository"
    AuthUserFile /etc/apache2/dav_svn.passwd
    Require valid-user
</Location>
share|improve this question

Yuo have an auth file to store the users, but no access file. Try adding

AuthzSVNAccessFile /var/myrepos/conf/svnaccess.conf

where svnaccess has the groups specified and the user permissions.

share|improve this answer
    
This is the answer! – Citizen May 14 '15 at 8:09

I also had this problem with websvn. This is how I solved it:

First you need to have a svnaccess.conf file with the user permissions in it and it set as @gbjbaanb suggests. Then you need to have websvn reference that file in its config.

websvn/include/config.php

$config->useAuthenticationFile('/var/myrepos/conf/svnauth.conf'); // Global access file
share|improve this answer

AuthzSVNAccessFile should work. You can also use http method limit / apache.

http://stackoverflow.com/questions/484499/how-do-i-restrict-apache-svn-access-to-specific-users-ldap-file-based-authentic

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.