Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have Ubuntu 10.04 dedicated server with SSD drive. Hence I want to disable the file system journal.

Normally this can be done like this "tune2fs -O ^has_journal /dev/md2". However the root file system is in read-write mode so tune2fs prints an error. The "-f" does not work.

Maybe during boot there is some script which is executed having root file system mounted read-only. So I can add above command to that script.

BTW I can reinstall OS but ext2 isn't available. A server provider admin web page doesn't allow to pass create partition options when reinstalling OS.

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

You should be able to remount the root partition read-only if you can afford to turn off enough services for a few minutes. Use lsof +f -- / to find out what programs have files open for writing. In particular, if /var/log is on the root partition, you'll have to turn off logging; and /tmp had better be on tmpfs or a separate filesystem.

If your hosting provider gives you console access, you can pass init=/bin/sh on the kernel command line (this runs a shell instead of init) and run tune2fs from there.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.