Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

This is my first question on ServerFault (although I have had good results with StackOverflow) so if anything is outside the rules or not clear please tell me.

I have a website (Joomla) at http://www.3ahukuk.com (also www.3aturkishlaw.com but that is probably not relevent) hosted on IIS6 (unfortunately I only have IIS7.5 on my test system on my W7 PC) and using SMTP mail server webmail.3ahukuk.com

When I send from the website contact form it does not get through and no error shows up on the Joomla message. I doubt there is any problem with Joomla as mail worked fine when I previously tested with smtp.gmail.com and set it to log on to my personal user-id.

There is a server in the customer's office which I think runs their Lotus Notes. In Lotus Notes there is a group info@3ahukuk.com which contains email addresses for the 2 people who will receive the
emails. When I send an email (not from the website but directly from my personal Google Apps email) to info@3ahukuk.com it gets through fine to the two people. But as mentioned from the website it does not. All the characters in the email addresses are Latin alphabet.

However if I log in to the ISP control panel and forward info@3ahukuk.com to my own email address website email gets through fine (as the volume of mail is small at present I have left it at that for the moment as a temporary fix). However if in that control panel I forward to one of the above people it does not get through.

The DNS records include: MX1 A 85.105.108.144 MX2 A 89.19.0.249 webmail.3ahukuk.com A 89.19.0.248

At one point about a week ago the webmail was working briefly however the customer and/or the hosting company made some change (I have been unable to find out what) as they tell me they were having problems with their Lotus Notes email. I asked if there might be any clues from the IIS SMTP log but they have not sent me anything. Now the customer's Notes email is working OK.

Please note my knowledge of SMTP and IIS and Lotus Notes is very limited. I assume the above DNS records mean there are SMTP server(s) at both the hosting company and the customer site? But I don't understand how they relate (or interfere) with each other and whether it is correct that the 'info' address should exist on both.

Any clues why forwarding to myself works but forwarding to the customer does not? Or how I could investigate further (I understand how to test with telnet but got no clues there) or make some permanent work around?

Regards

Geoff


I just ran some diagnostics so am adding the information (password removed and beginning of email address I am trying to send to changed but I know it exists on Lotus Notes) and changing the title:

Connecting to mail server.
Connected.
220 cluster03.natrohost.com ESMTP Natrohost.MailServer v.1.0.4 - MX2
EHLO Desktop
250-natrohost.com [78.189.189.73], this server offers 4 extensions
250-AUTH LOGIN
250-SIZE 26214400
250-HELP
250 AUTH=LOGIN
AUTH LOGIN
334 VXNlcm5hbWU6
aW5mb0AzYWh1a3VrLmNvbQ==
334 UGFzc3dvcmQ6
??????????????
235 Authenticated
RSET
250 Requested mail action okay, completed
MAIL FROM: <info@3ahukuk.com>
250 Requested mail action okay, completed
RCPT TO:<XXXXX.YYYYY@3ahukuk.com>
550 Requested action not taken: mailbox unavailable or not local
161: 550 Requested action not taken: mailbox unavailable or not local
QUIT
221 Service closing transmission channel
Disconnected.

So does that mean it is trying to send back to itself at webmail.3ahukuk.com instead of to the Lotus Notes server? And if so how do I tell it to send to Lotus Notes (presumably at the above mentioned MX1 A 85.105.108.144)?

share|improve this question
    
I just tried to send to –  Geoff Kelsall Oct 5 '10 at 9:48
    
info@mx1.3ahukuk.com but that said: 554 Relay rejected for policy reasons. –  Geoff Kelsall Oct 5 '10 at 9:49
    
So is it possible to change policy to allow mailserver webmail.3ahukuk.com to send to mx1.3ahukuk.com or mx2.3ahukuk.com and if so how? –  Geoff Kelsall Oct 5 '10 at 11:15
    
It was a little hard to follow your question, but I think you may have multiple issues. SMTP error 550 indicates the mailbox you're trying to send to doesn't exist or is unavailable. SMTP error 554 indicates your server has been blacklisted or blocked from sending mail to the recipient server. What server were you connecting to to get that log you put up? –  CIA Sep 28 '13 at 13:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.