Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to install Ubuntu server on a R210 with a S100 raid controller. It's a software controlled RAID, and it's not recognized in Ubuntu. So I guess I have to disable it and use the software raid provided in Ubuntu (mbabm).

I'm a bit lost about the process. In the BIOS, I can select RAID or AHCI. I don't know which one to choose. Then in the booting, I can press CTRL+R to access the RAID options. Should I use the nonRaid option again there ?

It seems that the appropriate driver (mtp2sas) is not present on the server version. So I have downloaded the desktop version, on which I'll add the ubuntu-server package. Am I right there ? Should I follow this procedure to configure the raid ? (https://help.ubuntu.com/10.04/serverguide/C/advanced-installation.html)

Thank for your guidance !

share|improve this question
    
As Hubert said, I disabled the Raid option and created a software RAID during the installation. After first restart, I get an error message, saying mounting /dev/disk/by-uuid/[...] on /root failed. –  Jonathan Sep 30 '10 at 11:42
    
The bug is explained here: bugs.launchpad.net/ubuntu/+source/partman-base/+bug/569900 - to fix it, partitions have to be installed manually, with some space left on each disk. –  Jonathan Sep 30 '10 at 11:59

1 Answer 1

up vote 1 down vote accepted

The RAID/AHCI setting is for the controller integrated in the mainboard, not the add-on card.

And yes, you need to disable all RAID settings in the add-on card, this way it should be seen as a simple SATA controller which are supported in linux. The howto you provided should guide you through the configuration.

share|improve this answer
    
So the first setting (RAID/AHCI) has no influence whatsoever on my configuration ? –  Jonathan Sep 30 '10 at 8:47
    
Yes, in fact, most mainboards from linux perspective don't behave differently with RAID and AHCI setting. Though it's better to leave this setting at AHCI, just to be safe. –  Hubert Kario Sep 30 '10 at 9:04
    
Thanks for the advice ! –  Jonathan Sep 30 '10 at 10:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.