Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I folks,

I want to build this scenario: one public server (openSuSE + Apache2 + Zope/Plone) and other private server with web applications (openSuSE + Apache2 + Zope/Plone).

I want users think they are working only with one server (SSO is already configured and works fine).

I installed mod_proxy_html in public server. And now I can 'route' traffic between the servers except only when the application submit an HTML form. In this case the URL changes to the private server.

RewriteRule ^/Intranet/Apps/app1(.*) http://private.dom.com:8080/VirtualHostBase/http/private.dom.com:80/CELLS/VirtualHostRoot/Intranet/Apps/app1/$1 [L,P]
ProxyPassReverse / http://public.dom.com:8080/VirtualHostBase/http/public.dom.com:80/DOM/VirtualHostRoot/

ProxyHTMLDoctype XHTML
SetOutputFilter DEFLATE;proxy-html;INFLATE
ProxyHTMLURLMap http://private.dom.com http://public.dom.com

ProxyPassReverseCookieDomain .private.dom.com .public.dom.com
ProxyPassReverseCookiePath / /

I don't know what I'm doing wrong or what I miss to configure :-(

Thanks in advance, Oscar.

share|improve this question
    
What is your version of mod_proxy_html? Newer versions need ProxyHTMLEnable On to activate the module. –  Christian Sep 30 '10 at 12:22
    
I'm using version 3.1.2 and I think that only needs to put: SetOutputFilter proxy-html –  ocell Sep 30 '10 at 12:53
    
Adding ProxyHTMLEnable On I have the same problem. Without this directive the behavior was the same, as I can saw in logs. –  ocell Sep 30 '10 at 12:58
add comment

1 Answer

up vote 0 down vote accepted

Finally I see the light!

The only I need is this:

RewriteRule ^/Intranet/Apps/app1(.*) http://private.dom.com:8080/VirtualHostBase/http/%{HTTP_HOST}:80/DOM/VirtualHostRoot/Intranet/Apps/app1/$1 [L,P] 
ProxyPassReverse / http://private.dom.com:8080/VirtualHostBase/http/%{HTTP_HOST}:80/DOM/VirtualHostRoot/

And the key of this issue is on adding %{HTTP_HOST} (an Apache2 variable), disable the Apache2 in the private server, and the work will be done by the VirtualHostMonster on the private server.

Thanks for all of your comments and regards! Oscar.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.