Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Sharepoint website that runs on IIS inside VMware Workstation guest system.
The host is Windows 7, whereas guest is Windows Server 2003.

What I basically need is just to be able to browse the website from the host OS.

I guess this has something to do with setting up NAT and port forwarding but I can't figure how to make it work. I tried setting Network Adapter in VM settings to NAT option but had no luck whatsoever.

Update
There's also a different kind of problem here: my VM computer name is used by another computer in our network. I cannot change it because it would ruin Sharepoint configuration (already tried), and reconfiguring Sharepoint is something I want the least.

share|improve this question
add comment

2 Answers

You should be able to set up VMWare to bridge the network connection so your virtual machine appears as any other machine on the network. Configure it for DHCP or static IP, browse to the (virtual) machine, and you should have access.

share|improve this answer
    
How do I do it? I have nearly 0 experience with configuring the network. I also discovered another problem with names, I'll update the post to reflect it. –  Dan Sep 30 '10 at 14:45
    
You might have to google for vmware workstation bridged network and find a link that works, but this might work: vmware.com/support/ws55/doc/… –  Bart Silverstrim Sep 30 '10 at 18:39
    
It might also be in your help files for networking (look for bridged instead of NAT.) –  Bart Silverstrim Sep 30 '10 at 18:40
    
Don't know about your computer name dilemma; technet.microsoft.com/en-us/library/cc261986.aspx May help. Other alternatives; rename the other computer, or post it as a separate question on SF and see if some sharepoint gurus can chime in. –  Bart Silverstrim Sep 30 '10 at 18:43
add comment
up vote 0 down vote accepted

I have successfully solved the problem.
These are the steps I had to take:

  1. Set Network Adapter mode to Host-only in VM settings.

alt text

  1. Disconnected and connected Network Adapter in VM settings.

  2. Run ipconfig in guest command line to find out VM's IP.

  3. Edited hosts on host system to map this IP to machine name (this also solved name ambiguity)

alt text

Voila!

alt text

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.