Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We recently moved from Exchange 2003 to 2010, and have noticed a quirk that is annoying us.

If our exchange server (single server) goes down, ie it gets rebooted, or client loses connectivity (or for example a reboot is done overnight and the users computer is on at the time) they will be prompted to login, and will have to use the full domain\username notation in their username field in order to login again. Either that or reboot outlook.

Its not a big deal, but lots of inexperienced users are confused by this, and some dont realise they need to do something and thus their outlook sits there without receiving emails until they finally notice.

This used to be seamless, what do I have to do to get that back again?

share|improve this question
    
Great question. This also occurs with Exchange 2007/Outlook 2007. –  Skyhawk Sep 30 '10 at 21:37
    
Interestingly enough, I get this in 2003 when we reboot the server - however the OP says their installation used to be seamless. Interesting indeed. –  Ben Pilbrow Sep 30 '10 at 21:40
    
Is your Exchange server on the same network as you clients, or are you connecting to a remote location? –  Sam Oct 1 '10 at 9:20
    
all on the same network/physical location, we do sometimes use remote access, but the majority of users don't. –  RodH257 Oct 1 '10 at 13:45
add comment

4 Answers

up vote 2 down vote accepted

This is because the Outlook account settings were configured with "Outlook Anywhere" turned on. You can turn it off, if you do not want it.

So that when exchange is rebooted, it will loose connection and restore it once it is back online, and it will not try to connect via https - Outlook Anywhere.

I normally advice my user to restart outlook. If they enter their credential, it will change their connection to exchange from native connection via lan to HTTPS.

share|improve this answer
2  
This might be relevant if Outlook Anywhere is set to connect using Basic authentication and they have to enter their password normally when opening Outlook. If Outlook Anywhere is set to use NTLM authentication, it should use their credentials automatically and not prompt for passwords. –  TessellatingHeckler Oct 16 '10 at 1:51
1  
I see this behavior even with Outlook Anywhere configured to use NTLM - indeed it shouldn't prompt, but it does (only after an exchange server reboot where connectivity is lost) Users are not normally prompted - ever, not even once - except following a reboot of exchange if Outlook was open during the reboot. –  Joshua McKinnon Dec 30 '11 at 19:43
    
Outlook Anywhere is activated and uses NTLM, but I disable it for my local domain via GPO. Still, when I reboot the server Outlook asks me for a password. –  Sirber Feb 22 '12 at 18:17
add comment

I am also experiencing the same issue, it is odd that only some people experience it. Also I rebooted the server over the weekend whilst the PCs were off and some people were still prompted on Monday morning.

I'm worried turning Outlook Anywhere off will affect my external users.

Maybe you can try this, I have been unable to test it yet: Outlook > Tools > Account Settings > Change > More Settings Connection Tab > Uncheck "connect to my exchange mailbox using http".

Have you installed all the exchange update rollups?

This thread has some advice in it also: http://www.dslreports.com/forum/r24512375-Outlook-2007-Exchange-2010-prompting-for-usernamepassword

share|improve this answer
add comment

You may see this behaviour if Outlook is configured to use Kerberos authentication only and the time difference between the client clock and the server clock is off by more than 5 minutes.

share|improve this answer
add comment

Create a batch file on the all users desktop with the following:

NET STOP msexchangerpc Shutdown -r -t 15

Always use this to restart the system. It shuts down the service that causes users to have to log back in. Worked in our case at least.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.