Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Please excuse (or even better, correct) my misuse of terminology here, I'm a bit of a noob at this.

On my companies internal network, on the DNS server (server 2k3), if I create an AName record to an internal machine, say:

AndrewsPc 192.168.0.1

this works fine, and can be accessed from any networked machine no problem.

However, subdomains do not work without being fully qualified with the domain name. For example:

for the internal webserver i set up an AName like this:

CruiseControl 192.168.0.1

I'd like the sites on it to be configured as:

MySite.CruiseControl 192.168.0.1

however, the only way to access these sites is via:

MySite.CruiseControl.MyDomainName

where as i can Access CruiseControl via just CruiseControl i.e. it doesnt need to be CruiseControl.MyDomainName

I'm pretty sure I've setup dns records in exactly the same way on other networks and had no problem (i.e. not needed to add the domain on the end).

What is causing this and how do I make it so i can access subdomains without needing the full domain path?

share|improve this question

6 Answers 6

First, I will assume that you added your subdomain under the main domain that your internal network is using.

MyDomain
|--CruiseControl

Make sure that your clients all have the Append primary and connection specific DNS suffixes stetting enabled in the Advanced TCP/IP Settings dialog for their adapter.

Also ensure that you are pushing the DNS Domain Name option via DHCP. It should be set up with your primary domain.

I've tested your scenario in our network and it works fine to resolve an address like MySite.CruiseControl without adding the TLD MyDomain to the query.

share|improve this answer
    
"Also ensure that you are pushing the DNS Domain Name option via DHCP. It should be set up with your primary domain." Where abouts is this setting? Thanks –  Andrew Bullock Jun 3 '09 at 13:39
    
It is located in the DHCP management snap-in on the server that handles DHCP for your network. Under Administrative Tools there is a DHCP shortcut. You should see the server name listed, when you open that there is a Scope Options icon on the left. If you do not see it in the option in the list on the right, you can simply right-click, choose Configure Options and scroll to 015 DNS Domain Name. Check it and edit the Data entry String Value below. –  palehorse Jun 3 '09 at 15:24
    
It would appear to already be configured :( any other ideas? –  Andrew Bullock Jun 4 '09 at 9:43
    
Have you tried to manually add the domain name suffix to one of your clients network setting? That would be a good troubleshooting step to see if that works or not. If it does not, then there may be something else going on. –  palehorse Jun 4 '09 at 11:59

If you run ipconfig /all, it probably shows something like this near the top:

DNS Suffix Search List: example.com
If you just want to resolve names without having to type the domain, i'd make it look like this (i.e. list **all** of your domains here):
DNS Suffix Search List: example.com
                        subdomain.example.com

Now when your computer tries to resolve a "short" name like mysite, first it will try mysite.example.com (since that's the first domain in the search list), and if it can't resolve that, it will try mysite.subdomain.example.com. Of course, you can order the domains any way you want.

If you have a Windows 2003 domain, then you'll probably want to configure the DNS search list via group policy so that you don't have to configure it manually on every machine.

share|improve this answer
    
my list just has "example.com". "ping subdomain" works. "ping sub.subdomain" doesnt. "ping sub.subdomain.example.com" does. im lost?! –  Andrew Bullock Jun 5 '09 at 12:27
    
Yes, "ping subdomain" works because "subdomain" is not fully qualified (i.e. the address you specified does not contain a dot). When you use short names like that, your machine appends the domains in the search list until it finds one that works (i.e. "ping subdomain" actually becomes "ping subdomain.example.com") When you type "ping sub.subdomain," your machine sees the dot in there and assumes you are typing a fully qualified domain name. Thus, the domain search list is not used. –  Mike Conigliaro Jun 5 '09 at 13:32
    
Ok, so how can i make it work? is that by adding "subdomain.example.com" to the list so that "sub.subdomain" resolves? Im sure i've had this working before without explicityly adding "subdmain.example.com" to the list (although perhaps it was in there automatically, can this be done?) thanks –  Andrew Bullock Jun 8 '09 at 13:58
    
I'm not sure how it worked for you before, but try adding subdomain.example.com to the search list, and I'm sure it will work again. I would suggest doing it with group policy, since that will make this work on every machine in your network in one shot. –  Mike Conigliaro Jun 8 '09 at 14:43
    
It looks like I was wrong in one of my previous comments. Using Wireshark, I have discovered that Windows will attempt to append the domains in your search list to addresses that contain a dot. This does not affect my answer though. –  Mike Conigliaro Jun 8 '09 at 14:57

You should only have one A record per IP address - instead use CNAME (alias) records.

Multiple A records for the same IP address can cause problems.

share|improve this answer
    
perhaps thats just me using the wrong terminology, ill check and get back to you. thanks –  Andrew Bullock Jun 3 '09 at 13:36

If you want to treat CruiseControl like a domain suffix, i.e. if you want to create site1.cruisecontrol and site2.cruisecontrol, then you can define a ZONE called "cruisecontrol" in your DNS server and create the records in it.

share|improve this answer
    
does a zone appear like a folder in DNS view? if so thats what ive done, and its not working :( –  Andrew Bullock Jun 3 '09 at 13:42

You need to pull the CruiseControl suffix via DHCP too, and using just site1 or site2 will work. and yes in Win2k3 a child domain is a folder on DNS view.

share|improve this answer

I know this is an old question but I want to provide an actual solution for others having the same problem.

I've just gone through this issue. I've decided just to post screenshots as they would be the quickest explanation. Basically when there's a dot in the DNS query, it's not considered an unqualified dns and so the connection-specific suffix is not applied.

Let's assume that my connection-specific suffix is "ss" and I want to create a web server on "pos" and "dev.pos". So a ping to "pos" will be automatically changed to "pos.ss" whereas a ping to "dev.pos" will stay as "dev.pos" and not be converted to "dev.pos.ss" before querying the dns server. Here are the screenshots I made to best illustrate the proper layout:

This screenshot shows that you should have a primary zone called "ss". You should have CNAMEs that point to their respective primary zones. So "pos" should point to the "pos" primary zone's A record. enter image description here

This screenshot shows that you can put in your subdomain as a CNAME that points to the A record in the primary zone (in this case, "pos"). enter image description here

So now you have unqualified dns requests automatically referring to the connection-specific dns primary zone "ss" wherein you have the CNAMEs pointing to their respective A records in their respective primary zones. FQDN requests like "dev.pos" are automatically reffering to the primary zone "pos" and finding it's associated CNAME record "dev".

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.