Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

in my Ubuntu VMWare guest I'm using bridged network to gain access to my lan. The network setup per see works, but the nameserver is set to my router (and works) although I'm running dnsmasq on another server to handle internal names (and forward to the router).

Where can I customize the network so I've my own nameserver and search path in /etc/resolv.conf ?

My /etc/network/interfaces looks like

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
#iface eth0 inet dhcp

I don't remember touching it, basic setup worked out of the box.

I think the default setup is using dhcp? At least dhclient is running.

My /etc/resolv.conf is

# Generated by NetworkManager
nameserver 192.168.1.1

and I'd like to read it:

# Generated by NetworkManager
nameserver 192.168.1.11
search home.

I'm not sure where to modify things so I don't screw the current setup.

thanks

share|improve this question

3 Answers 3

up vote 0 down vote accepted

I do not have Gnome in english, please apologize if the menu are a bit different.

It seems that you are using NetworkManager to manage your connections.

Look in NetworkManager configuration: Right click on its icon, "Modify Connections", select "auto eth0" connection -> modify -> IPv4.

Set "DHCP for address only", then put your custom settings there for DNS and search domains there.

share|improve this answer

The DNS server is being set via dhcp in your configuration. You'll have to tell Network Manager NOT to use the server suggested by DHCP, but to use a different one instead. I would try the following in /etc/network/interfaces

# The primary network interface
auto eth0
    dns-nameservers 1.1.1.1
share|improve this answer

On most linux systems you can just modify /etc/resolv.conf directly. Since yours says it was generated by NetworkManager, perhaps you should look into either setting these options in NetworkManager (by right clicking on the little network connectivity icon on your toolbar) or turning it off and managing the link yourself.

Some distros also have header/footer files that get prepended or appended to the /etc/resolv.conf file that allows you to suppliment whatever data NetworkManager tries to put in there.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.