Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Have set up a small website for a client however contact form submissions are not getting through to their email address. They have website hosted on one server and email on another although website and emails share the same domain.

The bounce back has this message attached:

550 Requested action not taken: mailbox unavailable or not local

It sends without issue to my email address and others but can't get to any on their domain.

Client's IT guy is a bit clueless so I'm unsure how he's configured the mail server?

Any suggestions? I can find out more info if it would help also.

Thanks!

share|improve this question
    
Duplicate of stackoverflow.com/questions/3855160/… –  gorilla Oct 4 '10 at 22:48
    
yes because it was suggested i ask the question here rather than @ stackoverflow –  timothyclifford Oct 4 '10 at 22:52
    
I am having the same problem serverfault.com/questions/186119/… but I do not have any answer yet. Please could you add more details (e.g. what mail servers you are running? On which of them does the 'sent to' address exist?) so we can eliminate potential suspects or get clues. Feel free to contact me directly if you wish. Regards Geoff –  Geoff Kelsall Oct 5 '10 at 9:02
add comment

2 Answers

up vote 2 down vote accepted

Managed to resolve my issue, not sure if it will fix yours Geoff but give it a go.

Basically, the DNS entries for the website were managed externally. This included DNS for the website and email.

Problem arose because my web server also contained DNS entries so when sending emails, tried sending to its own mail server rather than external, email address' didn't exist and hence got this message.

Hope this helps anyone in same position.

share|improve this answer
    
But what did you do afterwards? I have MailEnable installed on my system that handles mail just fine, but when I am trying to use ASPEmail or other mail component from ASP code, it gives me the same error and can not get out of it... Where do you think I should search for the error? –  user99403 Oct 30 '11 at 15:28
add comment

It generally means one of two things.

  1. Their mail is broken.
  2. You're not sending mail to the right spot.

To verify you're going to the right spot, check their MX record and see if that's where you're sending mail

nslookup -query=mx domain.com
share|improve this answer
add comment

protected by splattne Oct 30 '11 at 15:36

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.