Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After a long time wasted trying to get Bluepill to work for process management, I'm trying to get monit set up. I'm not a Sys Admin but know my way around *nix systems. I'm a bit stumped here.

When I run the command to restart all monit processes I get this output:

rails@george:/srv/fsg_distro$ sudo monit restart all
'delayed_job' trying to restart
'delayed_job' start: /usr/bin/env
delayed_job: process with pid 16901 started.
'delayed_job' failed to start
'george' trying to restart

However the process is not running when I check with PS. Not to mention it's not doing what it's supposed to so I'm pretty sure it's not working.

Then when I try to reload monit I get this:

rails@george:/srv/fsg_distro$ sudo monit reload     
Reinitializing monit daemon
monit: No daemon process found

even though I have a conf:

rails@george:/srv/fsg_distro$ ls /etc/monit/conf.d/            

Any idea how to troubleshoot this issue?

share|improve this question

I know this is a super old question, but I'm documenting my (potential) answer for future Googlers.

What worked for me was: sudo service monit start

There's also a decent blog post on this: Solve monit: error connecting to the monit daemon

This still might give you an error about not being able to connect to the server. Apparently monit talks to the monit daemon essentially over an HTTP connection, and you need to configure what HTTP ports monit should use (and from what source it should allow these connections to happen on).

Add these lines to your monitrc:

You need to add following to monitrc (or whatever port number and allow requirements make sense in your situation) :

set httpd port 2812
allow localhost

Source (for the HTTP information): the monit mailing list, 2009

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.