Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a MySQL server which is tied to localhost. I would like to change it to an ip address, for example 192.168.x.x . I tried using the administrator from MySQL toolbench, but i am unable to find any option to configure it.

Any guidance will be greatly appreciated. Thanks

-----------Edited-----------------

I have tried added the bind address in my.ini file

[mysqld]

# The TCP/IP Port the MySQL Server will listen on
port=3306

bind-address = 192.168.x.x

I am able to ping the ip, and when i do a telnet the response is 5.1.46 community and some gibberish characters.

And i am still unable to connect to MySQL via my ip. Thanks...

Kevin

share|improve this question
    
What operating system are you using? –  Brad Mace Oct 5 '10 at 5:19
    
@bernace Aside from the location of the my.cnf file, OS doesn't matter in this case. –  EEAA Oct 5 '10 at 5:41
1  
I sincerely hope you put a real IP address instead of 192.168.x.x. Why bother hiding the IP address anyway?? It's not like we can hack you on 192.168.0.1 - we'd have better luck breaking into 127.0.0.1 –  Mark Henderson Oct 6 '10 at 3:26
    
@ErikA, the OS will determine not just the location of the config file but even it's name. So yes, the OS is relevant. The name used in the question suggests it's a Windows system but it would of course be the wrong file entirely if the system is not Windows. –  John Gardeniers Oct 6 '10 at 4:13

4 Answers 4

up vote 0 down vote accepted

Probably you haven't the permission to log as root from a host different from localhost. Read this, so you can solve the problem.

share|improve this answer

bind-address in the configuration file or daemon command line.

share|improve this answer
    
Hi, i have tried the bind-address in the configuration file, and i am still unable to connect the MySQL via ip address.. Thanks –  Nivek Oct 6 '10 at 2:51

In your my.cnf file:

bind-address = 192.168.x.x
share|improve this answer
    
Hi there, thanks for the reply... I have added in bind-address = 192.168.x.x in the my.ini as i am using windows XP.... Restarted MySQL service. But i am still unable to connect via 192.168.x.x. Using the MySQL Administrator i login as serverhost: 192.168.x.x username: root password:"" Do i need to create a new connection for it?? –  Nivek Oct 5 '10 at 6:34
    
Can you ping the address 192.168.x.x from your LAN? –  lg. Oct 5 '10 at 7:11
    
yes.. i am able to ping it. –  Nivek Oct 5 '10 at 7:52
    
Am i missing out other configuration to it?? –  Nivek Oct 5 '10 at 7:52
1  
can you telnet to it (telnet 192.168.x.x 3306)? –  Jure1873 Oct 5 '10 at 14:07

Windows Firewall is disabled or well configured?

Mysql use TCP port 3306

share|improve this answer
    
Hi there, i have disable the windows firewall. And what do you meant by well configured?? Thanks –  Nivek Oct 6 '10 at 2:50
    
If your firewall is disabled, it isn't your problem. Well configured = configured to open Mysql port. –  lg. Oct 6 '10 at 8:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.