Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Greetings Experts,

I'm setting up a static NAT from outside to inside on my Cisco ASA5510, something like this:

# static (inside,outside) 123.45.67.89 192.168.1.254 255.255.255.255  
static (inside,outside) 123.45.67.89 192.168.1.254 255.255.255.255  
 ^  
ERROR: % Invalid input detected at '^' marker.

So then I try this to get some help:

# static ?  
ERROR: % Unrecognized command

How can 'static' be an unrecognized command?

I'm referencing this documentation:
http://www.cisco.com/en/US/docs/security/asa/asa71/configuration/guide/cfgnat.html

Some more info:

# show version

Cisco Adaptive Security Appliance Software Version 7.2(2)
Device Manager Version 5.2(2)

Compiled on Wed 22-Nov-06 14:16 by builders
System image file is "disk0:/asa722-k8.bin"
Config file at boot was "startup-config"

xxxxxxxxx-fw up 14 days 17 hours

Hardware:   ASA5510, 256 MB RAM, CPU Pentium 4 Celeron 1600 MHz
Internal ATA Compact Flash, 256MB
BIOS Flash M50FW080 @ 0xffe00000, 1024KB

Encryption hardware device : Cisco ASA-55x0 on-board accelerator (revision 0x0)
                             Boot microcode   : CNlite-MC-Boot-Cisco-1.2
                             SSL/IKE microcode: CNlite-MC-IPSEC-Admin-3.03
                             IPSec microcode  : CNlite-MC-IPSECm-MAIN-2.04
 0: Ext: Ethernet0/0         : address is xxxx.xxxx.xxxx, irq xx
 1: Ext: Ethernet0/1         : address is xxxx.xxxx.xxxx, irq xx
 2: Ext: Ethernet0/2         : address is xxxx.xxxx.xxxx, irq xx
 3: Ext: Ethernet0/3         : address is xxxx.xxxx.xxxx, irq xx
 4: Ext: Management0/0       : address is xxxx.xxxx.xxxx, irq xx
 5: Int: Not used            : irq xx
 6: Int: Not used            : irq xx

Licensed features for this platform:
Maximum Physical Interfaces : Unlimited
Maximum VLANs               : 50
Inside Hosts                : Unlimited
Failover                    : Disabled
VPN-DES                     : Enabled
VPN-3DES-AES                : Enabled
Security Contexts           : 0
GTP/GPRS                    : Disabled
VPN Peers                   : 250
WebVPN Peers                : 2

This platform has a Base license.

Serial Number: xxxxxxxxxxx
Running Activation Key: xxxxxxxxxx xxxxxxxxxx xxxxxxxxxx xxxxxxxxxx xxxxxxxxxx
Configuration register is 0x1
Configuration has not been modified since last system restart.
share|improve this question

1 Answer 1

up vote 2 down vote accepted

It looks like you entered those commands directly in 'enable' mode. You probably just need to enter configure mode.

ASA5510-01# configure terminal

or as a shortcut

ASA5510-01# conf t

Once you are in configure mode, the prompt and static command will look like this:

ASA5510-01(config)# static ? 
configure mode commands/options:
  (  Open parenthesis for (<internal_if_name>,<external_if_name>) pair where
     <internal_if_name> is the Internal or prenat interface and
     <external_if_name> is the External or postnat interface

And from there, any configuration commands should work.

share|improve this answer
    
+1. Also he could just hit question mark at the prompt he was at to give him a list of valid commands. –  JakeRobinson Oct 6 '10 at 2:41
    
Yup, that did the trick. Thanks! –  hawkexp Oct 6 '10 at 17:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.