Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Duplicity 0.6.10 doesnt seem to like the s3+http protocol. I keep getting the following error message.

unsupportedbackendscheme: scheme not supported in url: s3+http://<bucketname>

I've tried with 0.6.09 as well and no luck. I finally got down to 0.6.06 and was able to finally backup my system. Did I miss something? Changelog doesn't show any changes to the S3 protocol.

share|improve this question

2 Answers 2

Working on it...

As to Python 2.3, the only place it's mentioned is setup.py -- I just committed a fix for that.

share|improve this answer

I'm having the same problem. I've submitted a question ticket to the developers.

Update

The bug has been fixed by Duplicity developers. A patch against for the problem is now available.

Details: See the bug report

share|improve this answer
    
Yea I came across your ticket via google search. I've opened a separate ticket before regarding a different issue and it went unanswered. I may start looking at alternatives if I can't get help when I run into problems. –  luckytaxi Oct 6 '10 at 3:21
    
@luckytaxi: We'll see. I remain hopeful--I only submitted the question last night. Based on your report I also submitted a bug report to them. Duplicity has a good rep. Thanks for the idea of downgrading, I hadn't thought of that. –  LarryK Oct 6 '10 at 3:25
    
Me too. Duplicity refuses to work with python 2.3 and upgrading to 2.4 is out of te question. I've resorted to rdiff-backup on my rhel 4 boxes. –  luckytaxi Oct 6 '10 at 3:27
    
now im getting. BackendException: Boto requires a bucket name. –  luckytaxi Oct 7 '10 at 0:11
    
I created my bucket explicitly using the Amazon aws tool: timkay.com/aws Then I used duplicity. Also, are you using the damontimm script? See blog.damontimm.com/… –  LarryK Oct 7 '10 at 1:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.