Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

i install bluepill on ubuntu: Linux auto 2.6.31-14-server #48-Ubuntu SMP Fri Oct 16 15:07:34 UTC 2009 x86_64 GNU/Linux

Actual Result:


root@auto:/# gem install bluepill
Successfully installed bluepill-0.0.43
1 gem installed
Installing ri documentation for bluepill-0.0.43...
Installing RDoc documentation for bluepill-0.0.43...
root@auto:/# bluepill
bluepill: command not found
root@auto:/# 

I install bluepill on ubuntu: Linux autobot 2.6.27-7-server #1 SMP Tue Nov 4 20:18:35 UTC 2008 i686 GNU/Linux

stdout:

gem install bluepill Successfully installed blankslate-2.1.2.3 Successfully installed state_machine-0.9.4 Successfully installed bluepill-0.0.43 3 gems installed Installing ri documentation for blankslate-2.1.2.3... Installing ri documentation for state_machine-0.9.4... Installing ri documentation for bluepill-0.0.43... Installing RDoc documentation for blankslate-2.1.2.3... Installing RDoc documentation for state_machine-0.9.4... Installing RDoc documentation for bluepill-0.0.43...

How come i can install bluepill on one ubuntu and cannot on the other, is bluepill OS version dependent ? or needs some libs that are missing ? on my Linux auto 2.6.31-14-server

Thanks, -Kamal.

share|improve this question

1 Answer 1

Find binary file:

 find / -name bluepill

End execute(Ubuntu 10.04 + ruby1.8)

/var/lib/gems/1.8/bin/bluepill

Change PATH:

export PATH=$PATH:/var/lib/gems/1.8/bin/
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.