Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I need to restart snmpd after updating /etc/snmp/conf/snmpd.conf, so it recognizes the changes. I'm using Net-SNMP 5.4.2 on Opensolaris 10. I've tried these two:

snmpd restart
kill -9 pid

The kill command kills it and it fires back up under a new pid, but the new snmpd.conf changes do not seem to be recognized. I'm adding "disk /" to snmpd.conf, and testing to see what filesystems are mounted by:

snmpwalk -v 1 -c public localhost .

But this shows nothing, so I'm under the impression my addition of disk / is not taking. Am I restarting snmpd correctly?

share|improve this question
up vote 3 down vote accepted

This restarts snmpd:

svcadm restart net-snmp

By looking at

svcs -a | grep snmp

I realized the service is named net-snmp and not snmp, snmpd, or snmpdx. Opensolaris and snmp are both new to me.

share|improve this answer

kill -9 kills the process. have you tried kill -HUP?

From the docs:

The Net-SNMP agent can be instructed to re-read the various configuration files, either via an snmpset assignment of integer(1) to UCD-SNMP-MIB::versionUpdateConfig.0 (., or by sending a kill -HUP signal to the agent process.

share|improve this answer
I've tried kill -HUP on the snmpd pid, but the process still stays running, and with the same pid. – Banjer Oct 6 '10 at 17:10

Does Net-SNMP use the SMF?

If so, I would manage it with svcadm.

For example

svcadm disable snmpd
svcadm enable snmpd
share|improve this answer
I'm able to do svcadm disable snmp, but the process still runs for /usr/sbin/snmpd, so that doesn't seem to work either. Thanks though. – Banjer Oct 6 '10 at 17:12
My hint was nice, but the service name was another one: you found the correct solution. Great! – marcoc Oct 6 '10 at 18:35

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.