Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have set the time on the primary domain controller emulator but my clients don't seem to be adjusting there time.

  • The other domain controller did sync its time to the main controller
  • The domain controllers are VMs but the clients that should be syncing with them are not
  • The "Type" of the clients from w32tm /dumpreg /subkey:parameters is NT5DS
  • I don't see any errors in the event logs
  • I set the time about 6 hours ago and the clients are still 4 minutes off
  • A manual w32tm /resync gets a client to update its time, but that is not really a solution

Update:
I did a domain rename and renamed the dcs as well to corepsond. w32tm /query /peers /verbose shows the peer is still the old DC. Any know how I teach the clients about the new one?

share|improve this question
add comment

2 Answers

Is your PDC Emulator getting a good external-to-the-forest time sync? If your PDC Emulator doesn't have an authoritative time source configured I don't believe clients will sync. You can see more details at: http://support.microsoft.com/kb/816042

You may want to run a w32tm /resync on one of the machines and see if the clock syncs. That's quick-and-dirty, but it'll tell you if a sync is even possible.

Have a look at the output of w32tm /query /peers /verbose. That'll show you what the client's peer selection algorithm is coming up with.

Is anything blocking UDP port 123 traffic between the clients and their domain controllers?

share|improve this answer
add comment

To configure a client computer for automatic domain time synchronization Open a Command Prompt.

Type the following command and then press ENTER:

w32tm /config /syncfromflags:domhier /update

Type the following command and then press ENTER:

net stop w32time

Type the following command and then press ENTER:

net start w32time

source

share|improve this answer
    
That should just set the "Nt5DS" setting in the "Type" parameter of the W32Time configuration, which Kyle says is already set. (Having said that, I haven't come up w/ any ideas re: why the clients are still asking for the old DC name, though...) –  Evan Anderson Oct 6 '10 at 18:45
    
Try:w32tm /config /manualpeerlist:<external ntp server> /update; then net stop w32time && net start w32time; then run the commands above? –  Clint Oct 6 '10 at 19:22
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.