Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.


I currently am installing Tomcat6 as a windows service that will be controlled by a user account that cannot login, nor is the account a member of any groups. The issue I am seeing is that the service will be installed, but the service stops after 20-30 seconds saying that it didn't have any work to do. UAC is disabled at installation time, and the installation is done by a user in the administrators group. How can I resolve this issue to ensure Tomcat properly starts up?

share|improve this question

1 Answer 1

Have you tried following the steps available in the documentation for installing Tomcat 6 as a Windows service?

http://tomcat.apache.org/tomcat-6.0-doc/windows-service-howto.html

The safest way to manually install the service is to use the provided service.bat script. Administrator privileges are required to run this script.

NOTE: On Windows Vista or any other operating system with User Account Control (UAC) you must either disable UAC or right-click on cmd.exe and select "Run as administrator" in order to run this script. If UAC is enabled being logged on with an Administrator account is not sufficient.

The page provides some sample command lines to install Tomcat as a service (although the formatting does not work well when I copy and paste it into this answer).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.