Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Apache has been corrupted somehow and now it just displays the following error when going to any page.

Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace.

This is nothing to do with .htaccess, everything was working fine on multiple virtual hosts before my virtual machine screwed up some files.

I think the best idea is to reinstall the apache2 package.

I have tried apt-get --purge remove apache2 and apt-get --reinstall install apache2. Nothing seems to work, it just marks it as removed but doesn't actually remove the files.

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

apt-get remove apache2

mv /etc/apache /etc/apache.old

apt-get install apache2

share|improve this answer
    
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded. Need to get 0B/1,484B of archives. After this operation, 36.9kB of additional disk space will be used. Selecting previously deselected package apache2.... Looks like it just uses the old package. –  Keyo Oct 7 '10 at 2:44
    
Does it happily install a new /etc/apache ? –  Geraint Jones Oct 7 '10 at 2:45
    
I think I finally fixed it with sudo apt-get purge apache2 apache2-mpm-prefork apache2-utils apache2.2-bin apache2.2-common libapache2-mod-php5 –  Keyo Oct 7 '10 at 2:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.