Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am having a terrrible time getting this to work. I have configured the SharePoint site and the SQL Servers involved to use Kerberos. That has been confirmed working.

I then configured the SharePoint site's Reporting Services integration (trusted account), enabled anonymous access and enabled report builder. I can launch report builder without any issues at all. The problem comes when I try to save my report. When Report Builder is started Items->New-ReportBuilder Report it opens and display in the lower left hand corner "No current report server." When I close the Wizard dialog and click connect I enter http://server.fqdn.net and I receive the following error:

Connection failed:

Unable to connect to the server that is specified in the URL, 'http://servername.fqdn.net/'.

Make sure that the server is running, the URL is correct, and you have permission to use the server.

I have also tried http://servername.fqdn.net/reportsserver/. When I try that I receive a login prompt. When I enter my credentials it tries for a few seconds and then sends another login prompt. I installed the report server using default settings. The reporting services db is on the same server as sharepoint. The configuration and other databases are on a remote SQL Server. I am able to browse the http://servername.fqdn.net/reportsserver/ URL and see the directory structure in IE.

share|improve this question
add comment

1 Answer 1

up vote 0 down vote accepted
  1. The initial installation must have been bad because it would not let us download report builder.
  2. We turned on anonymous access based on a few articles we found online. This allowed us to download report builder.
  3. Report builder was unable to access the report server. This was the issue.
  4. I reinstalled but continued to enable anonymous access assuming it was required, even though I had not done it on the initial test deployment (which did work).
  5. I continued to get the error that the report server did not exist.
  6. I reinstalled again and tried another fix.
  7. I reinstalled a third time but did not enable anonymous access, because that was the only thing I could think that was different between the test site that worked and this one.

Self inflicted wounds.... Ugh.

share|improve this answer
    
There seems to be an element of the AAMs causing problems too. –  Robert Kaucher Oct 12 '10 at 23:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.