Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I was using a older version of SQL on my server, and it worked fine when only typing the servername,, I could directly connect to the server,

I recently installed a new instance of SQL, and Iam trying to connect to the new instance but it dowsne't work.

SERVERNAME/New_instance

CAn someone help me out? How can I reach the new SQL server?

share|improve this question
    
What version of SQL server are you using? What is the server name and the instance name? How are you trying to connect: enterprise manager? SQL Server Management Studio? –  Chris Anton Oct 7 '10 at 14:27
add comment

3 Answers

Make sure that the SQL Server Browser Service is running. Named instances run on a different port than the default instance (usually a dynamic port unless you changed the setting), the Browser service is what allows your client to connect to the name without using an explicit port number.

You can also try connecting by specifying the port number directly, this will bypass the need for the Browser service. Check the SQL Server errorlog of the named instance to determine the port the instance is listening on, then try connecting to servername,portnumber from your client.

If the above doesn't work, check to make sure that Windows Firewall (or any other firewall you may be passing through) is configured to allow SQL traffic on both the server and the client. It's possible that it's configured only to allow traffic on port 1433 which allows the default instance to work correctly, but not the named instance.

share|improve this answer
add comment

Your slash appears to in the wrong direction. Try: SERVERNAME\New_instance

share|improve this answer
    
I tried and it didin't work –  user56275 Oct 7 '10 at 14:40
add comment

Are you connecting remotely or on the server? Does your new instance have remote connections enabled?

share|improve this answer
    
yes Iam connecting remotley, and I did not install managment studio on server... Iam trying to conenct trougth my client, yes I have aneblaed remote conenctions –  user56275 Oct 7 '10 at 15:14
    
Have you tried [Server IP]\[Instance Name] format? Are you getting an error saying the server could not be found or a login error? –  Sean Howat Oct 7 '10 at 15:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.