Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm backing up a Linux machine (Ubuntu 10.04) with rsync over SSH.

If I specify for my path something like "home/jason" it works just fine. "home/jason" is translated into "/home/jason". But how do I back up my root directory, i.e. "/"? Logic would have it that, since a slash gets slapped onto the front of whatever you put for path, a blank path would come through as "/". That's not the case, though. A trick like "home/../" doesn't work, either.

How do I back up the root directory?

share|improve this question

3 Answers 3

I take it you've tried "/"? If that didn't work, what exactly were the symptoms?

share|improve this answer
    
The option I use is "Remote: Rsync Server". Since I'm doing a remote backup with rsync, I don't think "Volume: c" would make sense. If I select "Volume: c", the "Host" field gets disabled and other pertinent fields go away as well. Let me know if I'm misunderstanding. –  Jason Swett Oct 7 '10 at 15:11
    
No, I misread your question and my answer made no sense. Hence the edit. –  NPE Oct 7 '10 at 15:12
    
I have tried "/". The error simply said, "Invalid path." –  Jason Swett Oct 7 '10 at 15:53

I think you need to create a module for "/" in rsyncd.conf (on the box which you're trying to back up.)

Something along these lines:

[root]
  path = /
  comment = "The root directory"

Get rsyncd to reload the config, and you should be able to use "root" as the path in the Frontview GUI.

See http://linux.die.net/man/5/rsyncd.conf, especially the examples towards the end of the file.

share|improve this answer
up vote 0 down vote accepted

Turns out putting "." works because it translates into "/." which is equivalent to "/".

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.