Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I mistakenly screwed up my tex-live installation on lenny, by trying to locally install some squeeze packages.

I've got a list of packages that are in state 'pU', and I'd like to replace them all by the a clean known to be working repository version.

How do I do that?

share|improve this question
add comment

1 Answer

up vote 3 down vote accepted
apt-get --reinstall install mypackage

Option --reinstall will tell apt-get to install the given package, even if it believes that the same version is already installed.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.