Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've successfully got the channel from phone->PBX working on G279. I'm just trying to get the PBX->trunk to also be G279.

I did this by using FreePBX and putting in allow=g729,ulaw into each extension. As I'm using FreePBX and no asterisk expert I wanted to avoid editing sip.conf if possible.

The question is, how can get the same effect for the trunk?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

I am assuming that you have g729 codec module at this point.

In your trunk configuration page, in PEER Details fields

add

disallow=all

allow=g729

Make sure you do it in the same sequence as above. Also do the same in USER Details if you have any entry in this field.

share|improve this answer
    
worked perfectly, call quality restored, thank you very much! –  chrism2671 Oct 15 '10 at 14:43

There is an easier way to do this now. Navigate the "Asterisk SIP Settings" page and simply tick the codec. You can also use this page to change the priority of the authorized codecs...

http://pbx.yourdomain.com/admin/config.php?display=sipsettings
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.