Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just migrated an existing svn repository to a new server. Previously the users connected using tortoise-svn over http, and when committing, would have their revision associated with there user by the svn:author property.

However now, after the move the users connect using tortoise-svn over https, and revisions no longer have associated authors.

After some research, it is my suspicion that since users are now being authenticated during the creation of the https connection, and not by subversion, that information is not being passed with their revision changes. However I have not found any way in tortoise or further down the software chain to provide this information directly.

But, I could be totally wrong. Thanks for the help.

Software stack:
Tortoise-svn v1.6.10 connecting over https to...
Apache v2.2 on Ubuntu 10.04 running ...
mod_dav_svn with ...
Subversion v1.6.12

share|improve this question

No matter whether you are using http or https, Apache can send the authentication information to Subversion repository, provided the resource in question (the Subversion repository) is protected by authorization requirements. In the <Location> or <Directory> block for your repository (or higher up in the path), do you have either:

require valid-user

or something to the effect of one or both of these:

require user joe jane george
require group developers admins

If the repository is not actually requiring authorization for them, their authentication is deemed irrelevant and not passed on to Subversion, resulting in an anonymous commit.

Hope this sends you in the right direction.

share|improve this answer
Thanks Mark, I would upvote you because this could have been my problem. When I get the rep I will come back. – jphofmann Oct 12 '10 at 14:24
up vote 0 down vote accepted

The cause of my problem was that svn users were not authenticating at all.

After the initial setup of svn/apache, I added a rule to the http.conf file allowing access to users on the local network that also applied to the svn location. Causing the svn user to no longer be prompted for authentication. I did not notice this at first, because I thought my credentials were being cached by TortoiseSVN.

I was further confused because within the svn location block I was specifying 'Require valid-user'. Which, as it turns out only requires a user to be validated if and only if a user is provided. This does not prevent access to non-users.


share|improve this answer
I also had this specific problem when specifying Satisfy any, which essentially enabled anonymous access. We were authenticating with both htpasswd file and ldap via AuthBasicProvider file ldap, so just Require valid-user would have been sufficient. – Benjamin Mosior Apr 9 '15 at 15:22

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.