Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

On Debian Lenny I built my own ffmpeg. When i do ffmpeg --version inside of a sudo bash shell I get the version I just build. Outside of it I get the old version. When using sudo ffmpeg I get the new version.

How do I replace the old version of ffmpeg so my webapp can run the correct version of ffmpeg? I dont want to require sudo.

share|improve this question
    
I solved it by using whereis ffmpeg then replacing one with the other –  acidzombie24 Oct 7 '10 at 19:23
    
Good that you got it working, but it seems you fixed a symptom instead of the cause. Look deeper or it may bite you in the future. How about uninstalling the package the other binary came from, and fixing the difference in your PATH settings? –  Martijn Heemels Feb 12 '11 at 18:50
    
@Martin: see comment i left pjz. How do i fix the paths? i could try make install as a normal user but i dont know if that will work. –  acidzombie24 Feb 12 '11 at 19:48
add comment

1 Answer

The issue is almost certainly that your PATH is different when running sudo than not. You'll likely need to either uninstall the old ffmpeg or replace its binaries in /usr/bin (or wherever) with your own.

share|improve this answer
    
Thats what i am thinking but HOW? Actually i just updated my server os and will be doing this again this week/ -edit- oops, this answer isnt new, it was the comment that was new –  acidzombie24 Feb 12 '11 at 19:46
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.