Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have upgraded a Debian Squeeze machine recently, which was installed in February 2010 and was never upgraded after that. After the upgrade, while booting the machine prints some messages and after "waiting for /dev with devices" it does not print anything else. The system actually boots and works, is connectible through ssh. But we don't get any console or X output.

ps command shows the running getty processes. but no virtual console (ctr+alt+fX) shows a login prompt. Actually, I suspect the keyboard stops working as the "numlock" key does not light up the led. The gdm login is also not accessible.

I tried dpkg-reconfigure on console-setup and a few other packages, and rebooted after changes, but to no avail.

share|improve this question
    
Could you post the output of uname -a from the ssh connection? There is an issue with udev on upgrade that may be affected by kernel version. –  Andrew Oct 11 '10 at 18:10
    
Kernel is 2.6.32-5-amd64. I worked around the problem by nopat and nomodeset kernel option. –  hayalci Oct 21 '10 at 8:19

1 Answer 1

up vote 0 down vote accepted

I have added "nopat" kernel option, and I could get the console.

After, X driver(Nouveau) had problems, I alse added "nomodeset" to command line.

Now I can get the console and X (by vesa driver) and I left the issue there.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.