Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Is there any other way to refer to the root directory besides "/"?

I have a ReadyNAS Pro on which I'm trying to set up a backup. When it asks me what directory I want to back up, it wants me to leave off the leading slash. For example, it wants me to enter "home/jason" if I want to back up "/home/jason". This is problematic when I want to back up "/" because it won't accept "" as a path.

I've tried creating a symlink for "/" but that didn't work.

Is there any other way to refer to the root directory? Any other thoughts on how to solve the problem?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Try /. or /./ if it insists on it ending with a trailing slash.

Edit: Note that I'm not sure how RedyNAS does its backups -- If it's going to create a directory and copy files into it you may wind up with a horrible circular mess and a full disk... Test this on non-valuable data first :-)

share|improve this answer
    
The issue is not that it wants a trailing slash, but that it doesn't want a leading slash. –  Jason Swett Oct 8 '10 at 16:57
2  
If it assumes a leading slash (the path you provide is interpreted as /path) then . is (or at least should be) the root –  voretaq7 Oct 8 '10 at 17:04
    
Using simply "." seems to have worked. Thanks. –  Jason Swett Oct 8 '10 at 17:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.