Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I recently got a Windows VPS to host my client websites on. Everything is working okay but for one domain I forgot to check the www checkbox when creating the domain in plesk.

I thought that I just had to add a cname record with the following info to fix it:

Record type:            [ CNAME ]  
Enter domain name:      [ www ].restaurant-eureka.be  
Enter a canonical name: [ restaurant-eureka.be ]  

Now if you use www you get the default Plesk 'placeholder' website. I found others with the same problem on the Parallels forum but their servers were running Linux.

So if anybody could explain to me how to fix this for a Windows VPS that would be really great.

share|improve this question

3 Answers 3

up vote 3 down vote accepted

I have a plesk running on Linux, but maybe the interface is the same.
Adding the CNAME will not touch the webserver configuration at all, it will only create the DNS record.

If you forgot to check the "www" box you can go to the Domains page, edit the domain (not clicking on the domain name, check the box in front of the domain and use the edit button above).
On the following page "switch on" the "WWW prefix" field.

Again I only have access to a Linux based plesk - hope it helps you.

share|improve this answer
    
Thanks that's what I was looking for. –  Pickels Oct 9 '10 at 15:30
    
Just a small note, on the plesk install on media temple (currently v8.6.0) the button is labelled 'Group Operations' (rather than just 'edit'). –  Cargowire Jun 7 '11 at 10:49
    
This worked for me, but not until I restarted apache and psa on the command line. Not sure which did the trick. –  joeshmo Oct 12 '12 at 16:56

Fixed it with IIS and just adding an extra binding to the website. Didn't find how to do it in Plesk yet.

share|improve this answer
    
Glad you resolved this issue. Please be sure to mark your answer as "accepted" when you are able. –  jscott Jul 24 '12 at 0:28

I found the solution to work around on this case. Plesk control Panel > Domain > Domain Administrator > Rename Domain. Then check to the box, save it. This do the trick add binding to IIS, so you can open domain with/without prefix.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.