Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm running an ubuntu server (bitnami lampstack) vm in vmware-server on a windows host machine. The vm every 10-20 seconds stops responding to the host computer for no apparent reason. I can still access the vm and ping it on other network machines and over the remote console on the host, but it will periodically stop talking to the host in every other way -- no ping, no response from the webserver, no dns -- even though all are alive and kicking at the time.

Bridged networking, /etc/network/interfaces is pretty straightforward.

/etc/network/interfaces

ifconfig:

ifconfig

(sorry about the images -- no SSH at the moment)

When I ping the machine from the windows host, it looks like this:

Reply from 192.168.1.7: bytes=32 time<1ms TTL=64
Reply from 192.168.1.7: bytes=32 time<1ms TTL=64
Reply from 192.168.1.7: bytes=32 time<1ms TTL=64
Reply from 192.168.1.7: bytes=32 time<1ms TTL=64
Reply from 192.168.1.7: bytes=32 time<1ms TTL=64
Reply from 192.168.1.7: bytes=32 time<1ms TTL=64
Reply from 192.168.1.7: bytes=32 time<1ms TTL=64
Reply from 192.168.1.7: bytes=32 time<1ms TTL=64
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Reply from 192.168.1.7: bytes=32 time<1ms TTL=64
[repeat ad infinitum...]

Any ideas?

edit - upon further inspection, this is only happening on the host computer. Another network computer doesn't experience the problem -- at least not at the same time, although there is the occasional lone timeout every 30 attempts or so. On the host computer, it normally stops responding like clockwork every 20-second or so. I'm very confused, but I'm starting to think my windows configuration is to blame.

edit2 - tried setting a different ip for the vm, no luck ... only the host computer is having trouble.

Host computer talking to the router and other computers - no interruption

Other computers talking to the vm - no problem

Deferred host computer's dns to the router and told the router to connect to the vm's dns - host is getting uninterrupted dns now

Host trying to reach the vm 'directly' (ie. by network ip) - 15-seconds on, 15-seconds off. If it's an ip conflict, I have no idea the source.

Tried assigning the host computer a static network ip address. No difference.

Feels like someone's playing a cruel prank on me or something... anyone have a guess at all as to what I should test at this point?


UPDATE:


I added the host's mac address to the vm's arp cache manually:

  arp -s my.host.ip.address my:host:mac:addess

This fixed the problem ostensibly -- but when I reboot the vm it starts flaking again.

I don't understand this at all. The mac address is still there on reboot if I run arp -n, but I have to run that command again to make it respond without interruption. I guess it would help if I knew what the hell I was doing.

share|improve this question
add comment

4 Answers

This sounds to me like a IP address conflict.
Check if no other computer is also using that IP.

share|improve this answer
    
Started doing it again... arghlsd –  Greg Oct 9 '10 at 19:08
add comment
up vote 0 down vote accepted

Similar issues:

here, here

Cause not determined -- maybe something to do with vmware's bridging or NIC drivers. Plugged host mac into arp cache (arp -s host.ip host:mac) in rc.local script. Cheap fix, but I'm done picking at this one.

share|improve this answer
add comment

I'm having similar problems with KVM. The trouble is, I've got two identical host machines and only one is having problems.

share|improve this answer
    
Some blame this on a possible MAC conflict. If you copied/moved a vm from one physical machine to another make sure you tell vmware-server that you copied, rather than moved it when prompted. Looking at my router page, I thought my vm was getting assigned the host's mac address; I deleted ( /etc/udev/rules.d/70-persistent-net.rules ), removed the vm from vmware-server, added it back and said 'copied' -- got a new mac address. Router still sees the same mac. D'oh. Then, I did the arp -s fix I posted. Perhaps someone more familiar with Linux can explain eventually, but I'd try both of those. –  Greg Oct 11 '10 at 11:01
    
Woops -- sorry, I skimmed over the "KVM" part. The last fix may still apply. –  Greg Oct 11 '10 at 12:38
    
Yes, manually setting the ARP entries has helped me, but it isn't because of duplicate MAC addresses. For some reason the server doesn't properly respond to ARP requests. –  ptman Oct 11 '10 at 13:39
add comment

This may be a little late, but I was having this same problem. I think I must've hit "move" instead of "copy" when I setup the VM from a template I had created. I fixed this problem by editing the VMX file and deleting the lines that start with:

ethernet0.addressType
uuid.location =
uuid.bios =
ethernet0.generatedAddress =
ethernet0.generatedAddressOffset =
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.