Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a PXE Boot Setup for installing CentOS 5 and Ubuntu 10.04 via Kickstart. I use LVM and installing CentOS without any user interaction works but Ubuntu always asks to "confirm to write changes to disk and configure LVM" during partitioning. If I don't use LVM, Ubuntu will not ask for any confirmation and just partitions the disk.

The part of the kickstart file where I handle the partitions looks like this:

#System bootloader configuration
bootloader --location=mbr 
#Clear the Master Boot Record
zerombr yes
#Partition clearing information
clearpart --all --initlabel
#Disk partitioning information
part /boot --fstype ext2 --size 200 --asprimary
part swap  --size 1024
part pv.01 --size 1 --grow
volgroup rootvg pv.01
logvol / --fstype ext4 --vgname=rootvg --size=1 --grow --name=rootvol

How can I tell Ubuntu to always accept the settings without selecting "yes" on the screen? Is there something like a confirm all option?

share|improve this question

2 Answers 2

up vote 5 down vote accepted

Ok, I found the solution to my problem, you have to use the preseed option to confirm the LVM question. Just add the following line to the Kickstart file.

preseed partman-lvm/confirm_nooverwrite boolean true
share|improve this answer

In the file ks.cfg

preseed partman-lvm/device_remove_lvm boolean true
preseed partman/confirm_write_new_label boolean true
preseed partman/confirm boolean true
preseed partman/confirm_nooverwrite boolean true
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.