Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have the admin tools install on a Win 7 64 bit machine but would like to see the Exchange tabs in ADUC. Googling shows this is a popular request and the most common solution (and the only one which appears to work to all) is to install Exchange Server Management for Vista using esmvista.msi /q. That may well have worked on beta versions of Win 7 but is definitely not working with my OEM copy of Win 7.

Can this perhaps be made to work by installing from an Exchange 2007 CD (which I don't have at this time), bearing in mind that we have Exchange 2003 only? Can someone please offer a solution that works? I figure some of you must have solved this by now.

Edit: I don't know if this is relevant or not but the Win 7 machine is also running Office 2010 Pro.

About the bounty I had intended to award the bounty to gWaldo for having taken the extra steps to try to help me with this issue. However, as I was about to do so my screen started scrolling and I actually clicked on the answer posted by natxo asenjo, whose answer offended me, without realising it. Perhaps if I wasn't rushing I might have noticed but that's now history.

share|improve this question
Very few views and no answers. Let's see if a bounty makes a difference. I want the answer a lot more than the points. – John Gardeniers Oct 14 '10 at 4:14
did you try running the program in computability mode using the vista choice? – PHGamer Oct 14 '10 at 5:09
@PHGamer, see my comment to Muhammad's answer. – John Gardeniers Oct 14 '10 at 6:22
When you say it is not working in Win7, what does that mean? Errors out? Never shows up? Anything in the event logs? – JakeRobinson Oct 17 '10 at 2:36
@JakeRobinson, "not working" was referring to getting esmvista.msi to install. I've no got past that but there are no Exchange tabs in ADUC, which is really all I'm after, nor does ESM function, producing the error "MMC could not create the snap-in", with nothing in the event logs. – John Gardeniers Oct 17 '10 at 20:40
up vote 2 down vote accepted

This thread indicates that it may a preference may be set...

Or, if that doesn't work...

This Forum post (second response - marked answered) describes installing ADUC under Windows 7 from the command line using the /q (quiet) switch in order to manage Exchange 2003 properties. This is, of course, after installing the RSAT (Remote Server Admin Tools) found here.

Another solution (source) is when you get the error in your event log 'Product: Exchange System Manager — Error 1925. You do not have sufficient privileges to complete this installation for all users of the machine' Log on as administrator and then retry this installation. To remedy this, (even while logged on as a sys admin) launch command from the windows\system32 folder as an admin. The brought up a UAC prompt - accept - , and then try using ESM on Win7x64

share|improve this answer
does this work for amd64 windows 7 installations (which is what the OP has asked)? I think not ... – natxo asenjo Oct 18 '10 at 19:45
awwww... Revenge voting... how cute... In fact, the threads that I referenced don't specify whether they are 32- or 64-bit. Unfortunately, I don't have a Windows 7 machine to test on at the moment. But unless you can say that have tried it and it failed, I don't suppose you can say so either. – gWaldo Oct 18 '10 at 20:07
@gWaldo, there are a number of very similar articles/posts like that, all of which talk about pre-release versions of Win 7. I've come to the conclusion that Microsoft made a change in the release version of Win 7 because following that procedure does not work on the machines I've tested. I can get past the ESMVISTA issue by editing the MSI to remove the check for Vista but even after it installs ESM won't work and there are still no Exchange tabs in ADUC. – John Gardeniers Oct 18 '10 at 20:46
@John Gardeniers Have you tried installing the RSAT and then following the steps in ? My professional curiosity is piqued, but I've got to head home for the day. (This may become an issue at my work, also...) If you haven't, I'll I'll continue in the morning. – gWaldo Oct 18 '10 at 21:11
@hatxo asenjo Yes, you are right that it doesn't work, but I actually took the effort to exhaustively test and confirm. But as I read your answer, you never actually said that 'it just won't work', you told him "life is hard". You say that you had tried it, but you never actually said that in your answer. THAT would have been helpful information. "I tried [this] and [this] and [this], and I still couldn't get it to work on Win7x64" is a lot more informative than "life is hard." – gWaldo Oct 20 '10 at 12:45

While this technically doesn't install the exchange tools in windows 7, since the exchange 2003 tools are unsupported in windows 7 this is what I've done in the past (only works on pro and up):

  1. Grab Windows XP Mode
  2. Patch XP mode and join it to the domain
  3. Install ESM inside of XP
  4. Configure the short cut for Seamless mode if it doesn't auto configure (it should)

Its a bit of a PITA but the only way I have been able to get ESM tools working under Windows 7 reliably.

share|improve this answer
I already have an XP machine running on the Win7 box, although I use Virtualbox instead of "XP Mode", but I'me looking for a native solution. Eventually I don't want to have to run old operating systems just to get around poor design. – John Gardeniers Oct 17 '10 at 20:43
+1 This is exactly what I do, and it works really well in the sense that you don't have to deal with an entire VM - you just get the visualized ADUC window. I've been down this path and at the moment, I think this is as close as it gets to running ADUC with ESM "native" on Windows 7. – Cypher May 26 '11 at 1:01

Try this :

From an Exchange 2003 server, copy the following DLLs from the \program files\exchsrvr\bin folder in to a common folder (preferably in the path) such as \windows\system32 on the machine on which you want to manage Exchange attributes:

  • address.dll
  • escprint.dll
  • exchmem.dll
  • glblname.dll
  • maildsmx.dll
  • pttrace.dll

Close any instances of MMC. Ensure there are no instances running via Task Management Than run CMD (!IMPORTANT!) as administrator and type this

REGSVR32.EXE c:\windows\system32\maildsmx.dll

Then open your MMC

If that doesn't do it,

(Credit: source)

share|improve this answer
Unable to register the DLL when the files are in system 32. Able to register when placed in syswow64 although it throws error C007007E. Still no Exchange tabs. Of course my Exchange is 32 bits and the client is 64 bits, just to complicate matters further. – John Gardeniers Oct 14 '10 at 20:34
Have you tried installing a 32-bit version? – gWaldo Oct 14 '10 at 23:13
@gWaldo, a 32 bit version of what - ESM or Windows? The above procedure uses 32 bit versions of the files because that's all I have available to me. Windows must remain 64 bit because I have 16GB of RAM installed and no 32 bit licenses anyway. – John Gardeniers Oct 17 '10 at 23:25
I'm sorry, I meant installing 32-bit ADUC – gWaldo Oct 18 '10 at 12:36
@gWaldo, I've just installed a 32 bit version of Win7 as a VM and on that ESM still doesn't work but the Exchange tabs DO appear in ADUC, so this may well be a 32/64 bit issue. Unfortunately, that still doesn't help me. – John Gardeniers Oct 18 '10 at 22:56

I haven't tried this, but it might be worth a shot to use the MS Compatibility Administrator (in the ACT) to lie to ADUC - tell it you're running Vista or XP?

My suspicion is that this is doomed. Since MS has moved the Exchange data out of AD and back into Exchange (as it was in 5.5) - I have the sinking feeling that they may have rigged the Win7 ADUC to be unable to produce those tabs.

To be fair, the supplied reason for moving the information out of AD seems credible (easier/safer separation of permissions between AD and Exchange admins), but in the meantime, it makes administering 2003 in win7 (or 2007 in XP) pretty freakin cumbersome.

share|improve this answer
I'm suspect you're correct about the tabs not being possible in ADUC. Every article I've seen so far where people have claimed success talks about doing it on Win 7 beta but I suspect the release version has that capability removed. No luck so far with the Compatibility Administrator, as I've yet to work out how to even get ADUC listed in it. – John Gardeniers Oct 14 '10 at 21:03
I don't have a similar setup on hand atm, but maybe save it off as an .MSC? – Kara Marfia Oct 14 '10 at 21:57

I know this is not what you want to hear, but sometimes life is hard. Besides, now it is the exchange tabs that are not working, tomorrow you will come across the problem that the terminal services tabs are not working for a windows 2003 domain. So my advice is:

  • install a windows 2003 r2 terminal server in a virtual machine
  • install the exchange administration tools
  • login the management server for administrative tasks
  • get on with your life ;-) and prepare the upgrade of your exchange server or get an alternative for it (zimbra and zarafa come to mind as the most viable choices).

Actually, a management server is a great idea for windows networks. You only need to install the management tools in one place, they are inmediately available to all admins. No one needs to login as administrator, everyone has an admin account for admin tasks, a normal account for normal tasks.

share|improve this answer
@natxo, you're right - that's not what I want to hear and your answer is distinctly less than useful. Of course I can access ADUC, complete with all tabs, via RDP. That's not what I'm asking about though, is it? I actually though I was pretty clear about what I'm trying to achieve. – John Gardeniers Oct 14 '10 at 22:55
let's agree to disagree. My answer is more than useful though, you have not yet reached the mental point to accept some things you cannot fix :-). So go ahead and downvote me again, but your problem will stay the same. – natxo asenjo Oct 15 '10 at 4:36
@naxto, that's the same attitude some people had when Microsoft inflicted Vista on the world, yet that problem was rectified by an historic turnaround by Microsoft. Simply accepting what someone else thinks is acceptable would do nothing but drag us straight back to the Dark Ages. – John Gardeniers Oct 17 '10 at 20:47
@John Gardeniers Obviously you have not reached the level of enlightenment required to see and appreciate the level of genius encapsulated by my answer. Perhaps given time, luck, sacrifice, and a good dose of bonus intellect, you will be able to ascend to my level of insight. </snark> (P.S. Please give me the Rep! Signed, Natxo) – gWaldo Oct 18 '10 at 18:17
You're so funny. If I had wanted so bad the 500 points I would not be telling him to stop trying, would I? I have been in his shoes, so I know what I talk about. It will not work in his OS. I was just trying to save him time and frustration but I guess some people do not like that. Excuse me for trying to do that. – natxo asenjo Oct 18 '10 at 20:08

For x64 Win7, probably test this solution.

One of the commentor did this:

then run mmc /32 add the activeusers snapin and you can see all the tabs.
share|improve this answer
Tried that. ESMVISTA won't install on the release versions of Win 7. The MSI can be edited to allow installation but even then ESM won't work (complains about an error in the add-in) and there are still no Exchange tabs in ADUC. – John Gardeniers Oct 14 '10 at 4:54

doesnt solve the question but

  1. installed the Windows XP mode component (WindowsXPMode_en-us.exe from

  2. installed Windows6.1-KB958559-x64 and Windows6.1-KB977206-x64 (you might not needs those, depending on your computer hardware).

  3. once installed, Ive used the shortcut from the startmenu -> Windows Virtual PC\Windows XP Mode to setup and configure the virtual machine

  4. I've joined the VirtualPC to the domain, important for the exchange tools :) and after the restart closed the VirtualPC

  5. Presto!, the exchange management tools can now be started als a RemoteApp from the shortcut in the startmenu. Windows Virtual PC\Windows XP Mode Applications .


this is the exchange tools for Vista I would believe this should work for W7

share|improve this answer
Thanks but this is essentially a duplication of what Zypher already answered. – John Gardeniers Oct 18 '10 at 22:52
did not realise sorry – Trozz Oct 18 '10 at 23:01

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.