Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm having a very strange problem which I just can't get past.

The way our network is set up, we have 2 locations. The main office with all our PCs, and servers/ We are then joined to a local ISP via microwave link and they provide our internet gateway and house an additional storage server for us. All of the network infrastructure is within our office

The problem is...

When some PCs (and servers) are assigned IP addresses, they cannot ping the gateway or remote server however the remote server can ping the PC.

Most of our internal IP addresses work fine but specific ones (e.g. .29) has this problem all the time.

There is nothing else using the ip address and no other network problems. When we switch the IP on the PC, it works fine.

Please help, I'm going mad.

Thanks,

Steve

share|improve this question
    
Are you using a single subnet? If so, what is the network/netmask/default gateway you're using. Also, please list an example of an IP address that "works" and one that doesn't. –  EEAA Oct 12 '10 at 14:51
    
Yes, it's a single subnet. –  Steve McCall Oct 15 '10 at 12:17
    
It seems as though the ip addresses vary. I've now tried an ip that didn't work (20.0.0.29) and it's working fine. the gateway is 20.0.0.1 and subnet is 255.255.255.0 –  Steve McCall Oct 15 '10 at 12:18
    
Oh and I'm mainly using Windows 7 & Windows server 2008 R2, although I have seen the problem occur on a windows xp machine –  Steve McCall Oct 15 '10 at 12:28
9  
You are using 20.0.0.0/24 subnet internally? –  dunxd Feb 2 '11 at 10:53
add comment

4 Answers

VLANs, subnet masks, local firewalls, and duplicate IPs on network are the usual culprits.

What OS's? Whats the subnet? Whats the IP of the gateway? Is there any local firewall or security app running? Are you sure you don't have duplicate IPs? What's your ARP table look like?

I'm suspecting duplicate IPs. You say .29 is the bad one. Well, are you sure there's not already a .29 running somewhere? Can you ping it?

share|improve this answer
add comment

I would suspect that the restriction is occurring at the firewall. Check its logs at the time of the failed ping and see if the activity is recorded. If so, check what rule is causing this.

share|improve this answer
    
The traffic doesn't pass through the gateway when accessing the remote server and only passes through windows firewalls. –  Steve McCall Oct 15 '10 at 12:28
    
Is it possible that the port on the firewall is set to only receive IPs of a specific IP range? For instance, I know that if I have a Sonicwall port defined to receive 192.168.1.100-192.168.1.200 and I plug a machine into it with an IP of 192.168.5.100, the connection will simply fail. –  PMGoldstein Oct 20 '10 at 18:34
add comment

There are several possible explanations for this, but the two top probability explanations to me are:

A) Bad network configuration on the hosts. One way to verify could be to show us the configs, telling which OS/distribution, whether you're using DHCP and so on. Or you could assign the problem addresses to different hosts.

B) firewalling or incorrect routing on the gateway or even on the problem hosts themselves.

We'll need more information about your experiments to know for sure.

share|improve this answer
    
Mostly DHCP addresses, some static (servers etc) I tried switching the ips to different hosts and still had the same problem. Strangely though the offending ip I was testing is now working fine a few days later... –  Steve McCall Oct 15 '10 at 12:26
    
The traffic doesn't pass through the gateway when accessing the remote server and only passes through windows firewalls I still find it very strange that the host with the problem could not ping the remote server or gateway but the remote server could ping the problem host –  Steve McCall Oct 15 '10 at 12:27
    
@dotplus what do you mean by "bad network configuration" ? Can you give some examples? –  S List Mar 7 '13 at 10:10
add comment

When it happens again, do a route print and post that for us to take a look at. My suspicion is the routing table is messed up somehow.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.