Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Please I need your help, and here is my problem with an email header I get:

I use Postfix as SMTP and I don't want my Host Nameserver to appear in the email header, what changes should I do?

As you can see in the code bellow, here is the Host Nameserver : server1.mydomainname.com

Here is the full header:

Received: from server1.mydomainname.com (mydomainname.com [My Ip(111.11.111.11)])
Delivered-To: myemail@gmail.com
Received: by 10.150.95.9 with SMTP id s9cs39975ybb;
        Tue, 12 Oct 2010 10:04:11 -0700 (PDT)
Received: by 10.142.128.14 with SMTP id a14mr6566111wfd.384.1286903051027;
        Tue, 12 Oct 2010 10:04:11 -0700 (PDT)
Return-Path: <user@mydomainname.com>
Received: from server1.mydomainname.com (mydomainname.com [My Ip(111.11.111.11)])
        by mx.google.com with ESMTP id y15si19129610wfd.52.2010.10.12.10.04.10;
        Tue, 12 Oct 2010 10:04:11 -0700 (PDT)
Received-SPF: pass (google.com: domain of user@mydomainname.com designates 111.11.111.11 as permitted sender) client-ip=111.11.111.11;
Authentication-Results: mx.google.com; spf=pass (google.com: domain of user@mydomainname.com designates 111.11.111.11 as permitted sender) smtp.mail=user@mydomainname.com
Received: by server1.mydomainname.com (Postfix, from userid 2523)
 id D33A612980A1; Tue, 12 Oct 2010 17:04:09 +0000 (UTC)
subject: Hello
Message-Id: <20101012170409.D33A612980A1@server1.mydomainname.com>
Date: Tue, 12 Oct 2010 10:03:49 -0700 (PDT)
From: user@mydomainname.com
To: undisclosed-recipients:;

Thank you for the help,

share|improve this question
2  
did you check the myhostname variable in your main.cf set the way you want it to show? Also it is possible that the google mail server is doing a reverse lookup of your IP and the response is the hostname that you do not want. –  PHGamer Oct 13 '10 at 3:23

2 Answers 2

You could change the helo_name setting but, as noted by DandyPandy, receiving SMTP servers will still reverse look-up your MTA's IP address and make note of it.

http://www.manpagez.com/man/5/postconf/

share|improve this answer

You can't help that. All you can do is configure your server to advertise another name. Sometimes, please use white-label domains that give no clear indication of who they're coming from. That's the standard though and that part of the header is being put there by the receiving server (gmail).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.