Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.


I installed Vsftp in CentOS 5.5 Box, and configured it but when I type a command

ftp localhost

I get ftp command not found. here is my vsftpd.conf file

anonymous_enable=NO
local_enable=YES
write_enable=YES
local_umask=022

#pasv_min_port=3000
#pasv_max_port=3050


#anon_upload_enable=YES
#anon_mkdir_write_enable=YES
dirmessage_enable=YES
"/etc/vsftpd/vsftpd.conf" 125L, 4703C
xferlog_enable=YES

connect_from_port_20=YES

#chown_uploads=YES
#chown_username=whoever

#xferlog_file=/var/log/xferlog

xferlog_std_format=YES

#idle_session_timeout=600

#data_connection_timeout=120

#nopriv_user=ftpsecure

#async_abor_enable=YES

#ascii_upload_enable=YES
#ascii_download_enable=YES
#ftpd_banner=Welcome to blah FTP service.
#deny_email_enable=YES
# (default follows)
#banned_email_file=/etc/vsftpd/banned_emails
chroot_list_enable=No
# (default follows)
chroot_list_file=/etc/vsftpd/chroot_list
#ls_recurse_enable=YES

listen=YES

#listen_ipv6=YES
dirlist_enable=YES
pam_service_name=vsftpd
#userlist_enable=YES
tcp_wrappers=YES 
chroot_local_user=YES
share|improve this question
add comment

2 Answers

up vote 3 down vote accepted

I guess you have not installed this package or it was a minimal installation.
Please install this by using: yum install ftp.

The server config has nothing to do with the client, these are two separate packages.

share|improve this answer
    
ok thanks. but still I have one more problem, I i'm not able to connect from remotely from my desktop to server. –  m4k Oct 13 '10 at 7:43
    
@makdotgnu : Different problem, different question. Accept this answer if it solved your problem. –  Robert Munteanu Oct 13 '10 at 8:59
add comment

As @Paul says you will need to install the ftp client to access the ftp server from the localhost.

CentOS by default has the iptables firewall service enabled. To allow access from your desktop system you will have to configure iptables to allow access.

iptables -I  RH-Firewall-1-INPUT -p tcp -m tcp --dport 21 -j ACCEPT
iptables -I  RH-Firewall-1-INPUT -p tcp -m tcp --sport 20 --dport 1024:65535 -j ACCEPT
service iptables save
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.