Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

On my Windows server 2008, I have IIS 7, ColdFusion 9, and the virtual SMTP service installed.

I host several applications on the server that send emails using the virtual SMTP service. Each application has its own separate SMTP virtual server so that the FQDN in the email header will match the email from address. Each application also has its own public IP address and the SMTP server acts on different public IP addresses.

I have configured RDNS lookups for those IP addesses that match the FQDN, which should make email recipient happy.

However, to the email recipient hosts, those IP addresses are not actually the ones connecting; instead the recipient hosts see the WAN IP address of the router. Many of the mail recipients are rejecting our email because a RDNS lookup on that IP address fails. Simply adding a RDNS lookup for that address would not be a total solution, because we need distinct IP addresses for the different domain names on the machine.

How can I resolve this so that my email headers show the public IP address of the SMTP server and not the router?

share|improve this question
1  
The SMTP server receiving a message adds the "Received:" headers-- not the sending server. It sounds like your router is doing NAT and translating the source address for the outbound SMTP connections coming from your server computer to its WAN interface's IP address. –  Evan Anderson Oct 13 '10 at 17:28
    
Thanks guys. I had sent this problem to the router guy first and they had said it was a problem with the mail server config. I have resent it to him again and he has confirmed now that it is a router issue and is fixing it. –  Randy Oct 14 '10 at 14:54

2 Answers 2

up vote 0 down vote accepted

Since you've got individual public ip addresses for each SMTP service, it seems to me you need to configure a one-to-one NAT for each of those public ip addresses to each of the SMTP services internal ip addresses for both inbound and outbound traffic. That way when each SMTP service sends an email it's sent from the public ip address that you've defined in the rDNS records for that SMTP service.

share|improve this answer

You need to disable NAT in the router since it's apparent that it's enabled.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.