Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm having an odd problem where FreeSSHD doesn't start on boot about one in ten times.

I'm using it on Amazon EC2 instances actually, since there's a bug in Amazon's version of Xen which makes it impossible to use cygwin/openssh on their 64-bit instances.

So if I take one image of Windows Server 2008 Data Center with FreeSSHD installed and set to run automatically as a service, and spin up 40 instances, FreeSSHd doesn't start on around 4 of them. The service isn't started and there's nothing in the sshd log file.

In the Event Log I see:

A timeout was reached (30000 milliseconds) while waiting for the FreeSSHDService service to connect. The FreeSSHDService service failed to start due to the following error: The service did not respond to the start or control request in a timely fashion.

But there's nothing else wrong, it seems to just be intermittent. If I remote desktop in and start the service manually later, it runs fine.

Any tips here on how to mitigate this? I'm trying to automate provisioning of these systems, so I really need sshd to start reliably without manual intervention.

FreeSSHD isn't really maintained any more, so I suspect I need a more generic Windows answer to this. Increase the timeout? Is there a way to get it to try again?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Really? No takers?

I'm trying setting the Windows service recovery settings to restart the service if it fails, but I'm not sure if those take if the service never starts up in the first place. I'll see after another mass test.

share|improve this answer
1  
It appears to have worked. –  Ernest Mueller Nov 2 '10 at 1:28

It's likely that some dependency, the network service for instance, took longer to start up and ended up affecting the FreeSSHd service. If you are able to delay the service start of FreeSSHd using the procedure here by creating the appropriate dependency you are likely to see more reliable startups.

share|improve this answer
    
A good idea! The Amazon 64-bit problem with cygwin has gone away so we aren't using freesshd any more, but I will keep this technique in mind for other stuff that might need to bump down in the start sequence. Thanks. –  Ernest Mueller Aug 5 '11 at 13:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.