Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Running Bitnami's Ubuntu Wordpress Image on Amazon EC2. By default the WordPress install is at /wordpress and there is a static index.html file in the root. How do I configure Apache and WordPress to serve from the root instead of /wordpress?

I have tried the instructions on this page: http://digitivity.org/10/how-to-serve-your-wordpress-blog-from-the-root-directory-if-its-installed-in-a-subdirectory without success.

I have tried changing the document root to the folder serving the wordpress content, but that just breaks WordPress.

I know I am missing something simple, but not sure what. Any help would be appreciated.

share|improve this question
add comment

1 Answer 1

Try the following:

  1. First of all Log in the wordpress admin panel and change in the “settings” panel the URL.

  2. Stop Apache server: sudo /opt/bitnami/ctlscript.sh stop apache

  3. Edit the following lines in the /opt/bitnami/apache2/conf/httpd.conf file:

...

DocumentRoot "/opt/bitnami/apps/wordpress/htdocs"

...

Directory "/opt/bitnami/apps/wordpress/htdocs"

...

# Include "/opt/bitnami/apps/wordpress/conf/wordpress.conf"

...

  1. Start the server: sudo /opt/bitnami/ctlscript.sh start apache

if you are having trouble saving your changes due to permission problems, use:

:w !sudo tee %

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.