Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.


I installed Centos 5.5 and by deafult SElinux was disabled. I did changes in /etc/selinux/config and now it looks like this.

SELINUX=enforcing
SELINUXTYPE=targeted
SETLOCALDEFS=0

and rebooted the system. But even after the reboot when I do check the sestatus it shows disable. where I'm doing a mistake do I need to change any thing else?

EDIT :
I'm Using Rackspace Cloud server

share|improve this question

2 Answers 2

up vote 3 down vote accepted

You need to be running a kernel that supports SELinux. Most VPS providers use one that doesn't, since no one has cared enough to write SELinux rules that allow their VPS tools/mechanism to work.

Another possibility is that one or more kernel options are being passed via the bootloader which disable it. Check your bootloader configuration.

share|improve this answer
    
To check current kernel parameters: cat /proc/cmdline –  LatinSuD Oct 14 '10 at 8:29

It seems that if you create a support ticket with Rackspace they can enable SELinux support without using a custom kernel. I suspect they keep alternate kernels available and they simply switch it over on their end.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.