Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

An IT guy at work remoted into and installed SQL Server 2008 Developer on my terminal, and at first everything seemed to be set up correctly. However, when I go into the Management Studio, I can't connect. I know that it's finding the server correctly, but my windows account credentials haven't been added as an admin it seems. This seems to me to imply that when Mr. IT Guy installed it, he accidentally left his network account as the sole admin. Am I deducing this correctly?

I do have admin privelages on this computer (in Windows, not in the sql server installation apparently), and the server is installed locally, so it would seem that I should be able to override anything he did and set up my account as admin on the server. Is this possible? Or will he have to remote in and change the account permissions himself?

Thanks,
-Robert

P.S. This is not the same issue as this. Mine actually finds the server, but gives me "Login failed for user [my username]. (Microsoft SQL Server, Error: 18456)."

Update: The IT guy got back to me and told me it was on his end and fixed it (I believe without even remoting in somehow). Either way, it was not anything I was doing, which was my main question. Thanks for the response!

share|improve this question
    
See this question also: How to enable remote connections for SQL Server 2008 - serverfault.com/questions/7798 –  Justin Scott Jun 3 '09 at 19:26

2 Answers 2

It could be that he did the proper thing and revoked rights to the BUILTIN\ADMINISTRATORS group. However, the right thing to do is in fact causing you issues. I suggest you have him remote back in and grant your login SystemAdmin role rights if that is what you should have. He could also reinstate those same rights to the BUILTIN\ADMINISTRATORS group as well, but that is not recommended.

share|improve this answer

If the installation was done according to the best practices, then the answer from Tim Ford is the correct answer.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.