Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Im just installed nginx from source

but when run /etc/init.d/php_cgi start, there is a message:
Starting php-cgi: spawn-fcgi: can't find user name nginx

...one more I dont know about their permission.

previously I install nginx using yum (CentOS)

share|improve this question

2 Answers 2

This will create the user and set their shell to /bin/false so no one can start an interactive login as this user.

$ useradd -s /bin/false nginx
share|improve this answer
    
can you tell me why /bin/false? what is /bin/false? my previous server also shell to /bin/false but I have no idea about it –  kakals1 Oct 14 '10 at 13:38
    
/bin/false exists for one purpose - to provide a non-zero exit code. Contrast this with /bin/true, which always provides a zero exit code. The effect this has with regards to user accounts is that the user doesn't have a valid shell. –  EEAA Oct 14 '10 at 13:50

Try

$ sudo adduser --system --no-create-home --user-group --disabled-login --disabled-password nginx

Or

$ sudo adduser --system --no-create-home --user-group -s /sbin/nologin nginx
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.