Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a VirtualBox (v. 3.2.8) host with Linux and Windows guests.

The Linux machines are attached to the 'Bridged Adapter'. They work fine and I am able to log in into them with SSH from an external machine (my development machine).

The Windows machines are attached to 'NAT' and I am able to run them. The problem is that now I need them to be attached to the 'Bridged Adapter' because I need to access a server running on them from a developer machine in the office.

The problem is that if I switch them to 'Bridged Adapter' and I try to run them, I get this error: Error: failed to start machine. Error message:

Failed to open/create the internal network 'HostInterfaceNetworking-eth0' (VERR_PERMISSION_DENIED).
Failed to attach the network LUN (VERR_PERMISSION_DENIED).
Unknown error creating VM (VERR_PERMISSION_DENIED)
NS_ERROR_FAILURE (0x80004005)

Thanks, Dan

share|improve this question
    
Have you tried to add a new network device as a bridge ? i'm not using virtualbox but i did the same thing with vmware and it worked just fine. –  Guapo Oct 14 '10 at 16:07
    
No, I haven't. I will try that then –  Daniele Oct 14 '10 at 16:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.